summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml39
1 files changed, 22 insertions, 17 deletions
diff --git a/.travis.yml b/.travis.yml
index ee069e8..3847bde 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,23 +1,28 @@
language: python
sudo: false
-python:
- - 2.6
- - 2.7
- - 3.2
- - 3.3
- - 3.4
- - 3.5
- - nightly
- - pypy
- - pypy3
install:
- - pip install -e .
- - pip list
-script:
- - python pycodestyle.py --testsuite testsuite
- - python pycodestyle.py --statistics pycodestyle.py
- - python pycodestyle.py --doctest
- - python setup.py test
+ - pip install tox
+script: tox
+matrix:
+ include:
+ - python: 2.6
+ env: TOXENV=py26
+ - python: 2.7
+ env: TOXENV=py27
+ - python: 3.3
+ env: TOXENV=py33
+ - python: 3.4
+ env: TOXENV=py34
+ - python: 3.5
+ env: TOXENV=py35
+ - python: 3.6
+ env: TOXENV=py36
+ - python: nightly
+ env: TOXENV=py37
+ - python: pypy
+ env: TOXENV=pypy
+ - python: 3.5
+ env: TOXENV=flake8
notifications:
email: