summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile12
-rwxr-xr-xtestsuite.sh4
2 files changed, 10 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 2abc74f..973ece9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,14 @@
+test :
+ python pep8.py --testsuite testsuite
+
+multitest :
+ python2.4 pep8.py --testsuite testsuite
+ python2.5 pep8.py --testsuite testsuite
+ python2.6 pep8.py --testsuite testsuite
+
selftest :
python pep8.py --repeat pep8.py
-test :
- python pep8.py --testsuite testsuite
+doctest :
+ python pep8.py --doctest
diff --git a/testsuite.sh b/testsuite.sh
deleted file mode 100755
index 5663d50..0000000
--- a/testsuite.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-python2.4 pep8.py --testsuite testsuite/
-python2.5 pep8.py --testsuite testsuite/
-python2.6 pep8.py --testsuite testsuite/