summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 887d567..11e86f8 100644
--- a/Makefile
+++ b/Makefile
@@ -1,17 +1,24 @@
test :
python pep8.py --testsuite testsuite
-multitest :
- python2.4 pep8.py --testsuite testsuite
- python2.5 pep8.py --testsuite testsuite
- python2.6 pep8.py --testsuite testsuite
-
selftest :
- python pep8.py --repeat pep8.py
-
+ python pep8.py --repeat --statistics pep8.py
doctest :
python pep8.py --doctest
-
alltest : test selftest doctest
+
+multitest :
+ python2.3 pep8.py --testsuite testsuite
+ python2.4 pep8.py --testsuite testsuite
+ python2.5 pep8.py --testsuite testsuite
+ python2.6 pep8.py --testsuite testsuite
+ python3.0 pep8.py --testsuite testsuite
+ python3.1 pep8.py --testsuite testsuite
+ python2.3 pep8.py --repeat --statistics pep8.py
+ python2.4 pep8.py --repeat --statistics pep8.py
+ python2.5 pep8.py --repeat --statistics pep8.py
+ python2.6 pep8.py --repeat --statistics pep8.py
+ python3.0 pep8.py --repeat --statistics pep8.py
+ python3.1 pep8.py --repeat --statistics pep8.py