summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Quast <contact@jeffquast.com>2016-06-06 13:15:44 -0700
committerJeff Quast <contact@jeffquast.com>2016-06-06 13:15:44 -0700
commitd2664ffe568d9bbea007397d42519acdb256cfe7 (patch)
tree407126a3dcfb59d96cf5942b3d44d333a24c911a
parente5eb99c9bc9e19241c3d42e78fcc91d088b84251 (diff)
parent0c9a789b990d3b4d8244a2fca77bcf1fbbd30f25 (diff)
downloadpexpect-d2664ffe568d9bbea007397d42519acdb256cfe7.tar.gz
Merge remote-tracking branch 'origin/master' into spawn_env_path
-rw-r--r--.gitignore1
-rw-r--r--README.rst2
-rw-r--r--doc/conf.py2
-rw-r--r--doc/history.rst2
-rw-r--r--pexpect/__init__.py2
-rw-r--r--pexpect/expect.py2
-rw-r--r--pexpect/pty_spawn.py1
-rw-r--r--setup.cfg3
-rw-r--r--setup.py6
9 files changed, 15 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
index 8777ca7..914c903 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,3 +7,4 @@ MANIFEST
*~
.coverage*
htmlcov
+*.egg-info/
diff --git a/README.rst b/README.rst
index 544d190..f03be78 100644
--- a/README.rst
+++ b/README.rst
@@ -32,7 +32,7 @@ You can install Pexpect using pip::
pip install pexpect
-`Docs on ReadTheDocs <http://pexpect.readthedocs.org/>`_
+`Docs on ReadTheDocs <https://pexpect.readthedocs.io/>`_
PEXPECT LICENSE::
diff --git a/doc/conf.py b/doc/conf.py
index 1e65318..992c286 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -54,7 +54,7 @@ copyright = u'2013, Noah Spurrier and contributors'
# The short X.Y version.
version = '4.1'
# The full version, including alpha/beta/rc tags.
-release = '4.1.dev'
+release = '4.1.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/history.rst b/doc/history.rst
index 1167865..f43afb7 100644
--- a/doc/history.rst
+++ b/doc/history.rst
@@ -106,7 +106,7 @@ new maintenance after a long dormancy, so some caution is warranted.
* Ignoring ``SIGHUP`` is now optional - thanks to Kimmo Parviainen-Jalanko for
the patch.
-We also now have `docs on ReadTheDocs <http://pexpect.readthedocs.org/>`_,
+We also now have `docs on ReadTheDocs <https://pexpect.readthedocs.io/>`_,
and `continuous integration on Travis CI <https://travis-ci.org/pexpect/pexpect>`_.
Version 2.4
diff --git a/pexpect/__init__.py b/pexpect/__init__.py
index 113ca22..c737663 100644
--- a/pexpect/__init__.py
+++ b/pexpect/__init__.py
@@ -75,7 +75,7 @@ if sys.platform != 'win32':
from .pty_spawn import spawn, spawnu
from .run import run, runu
-__version__ = '4.1.dev'
+__version__ = '4.1.0'
__revision__ = ''
__all__ = ['ExceptionPexpect', 'EOF', 'TIMEOUT', 'spawn', 'spawnu', 'run', 'runu',
'which', 'split_command_line', '__version__', '__revision__']
diff --git a/pexpect/expect.py b/pexpect/expect.py
index 1c7a163..660cfb5 100644
--- a/pexpect/expect.py
+++ b/pexpect/expect.py
@@ -44,6 +44,7 @@ class Expecter(object):
spawn.match = None
spawn.match_index = None
msg = str(spawn)
+ msg += '\nsearcher: %s' % self.searcher
if err is not None:
msg = str(err) + '\n' + msg
raise EOF(msg)
@@ -63,6 +64,7 @@ class Expecter(object):
spawn.match = None
spawn.match_index = None
msg = str(spawn)
+ msg += '\nsearcher: %s' % self.searcher
if err is not None:
msg = str(err) + '\n' + msg
raise TIMEOUT(msg)
diff --git a/pexpect/pty_spawn.py b/pexpect/pty_spawn.py
index e5b5814..eaf2f6f 100644
--- a/pexpect/pty_spawn.py
+++ b/pexpect/pty_spawn.py
@@ -205,7 +205,6 @@ class spawn(SpawnBase):
s.append(repr(self))
s.append('command: ' + str(self.command))
s.append('args: %r' % (self.args,))
- s.append('searcher: %r' % (self.searcher,))
s.append('buffer (last 100 chars): %r' % (
self.buffer[-100:] if self.buffer else self.buffer,))
s.append('before (last 100 chars): %r' % (
diff --git a/setup.cfg b/setup.cfg
index ae62686..87fce02 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,2 +1,5 @@
[pytest]
norecursedirs = .git
+
+[bdist_wheel]
+universal=1
diff --git a/setup.py b/setup.py
index e2ee117..801b3b8 100644
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,10 @@
from distutils.core import setup
import os
import re
+import sys
+
+if any(a == 'bdist_wheel' for a in sys.argv):
+ from setuptools import setup
with open(os.path.join(os.path.dirname(__file__), 'pexpect', '__init__.py'), 'r') as f:
for line in f:
@@ -38,7 +42,7 @@ setup (name='pexpect',
long_description=long_description,
author='Noah Spurrier; Thomas Kluyver; Jeff Quast',
author_email='noah@noah.org; thomas@kluyver.me.uk; contact@jeffquast.com',
- url='http://pexpect.readthedocs.org/',
+ url='https://pexpect.readthedocs.io/',
license='ISC license',
platforms='UNIX',
classifiers = [