summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..328cce9
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+
+setup(
+ name='pluginbase',
+ author='Armin Ronacher',
+ author_email='armin.ronacher@active-4.com',
+ version='0.1',
+ url='http://github.com/mitsuhiko/pluginbase',
+ py_modules=['pluginbase'],
+ description='A support library for building plugins sytems in Python.',
+ zip_safe=False,
+ classifiers=[
+ 'License :: OSI Approved :: BSD License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ ],
+)