summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Beazley <dave@dabeaz.com>2017-12-02 13:41:18 -0600
committerGitHub <noreply@github.com>2017-12-02 13:41:18 -0600
commit27b327ee75a84d4885a8b2aeea0f1a2297f44554 (patch)
treeb66a1a59a3d929408ddfbfb81fa1bae60483fc6c
parent7f9b69fe3ab9e2b17c73d1ed86b50f797843455e (diff)
parenta986c8d6a98c099332df4c2255350b6c756f85ad (diff)
downloadply-27b327ee75a84d4885a8b2aeea0f1a2297f44554.tar.gz
Merge pull request #128 from gvalkov/master
Simple makefile for common tasks
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b13d007
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+PYTHON ?= python
+
+test:
+ cd test && $(PYTHON) testlex.py
+ cd test && $(PYTHON) testyacc.py
+
+wheel:
+ $(PYTHON) setup.py bdist_wheel
+
+sdist:
+ $(PYTHON) setup.py sdist
+
+upload: wheel sdist
+ $(PYTHON) setup.py bdist_wheel upload
+ $(PYTHON) setup.py sdist upload
+
+.PHONY: test wheel sdist upload