summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Beazley <dave@dabeaz.com>2016-08-30 12:19:30 -0500
committerDavid Beazley <dave@dabeaz.com>2016-08-30 12:19:30 -0500
commit72cf37bfd40dfba8404bf434bc52d0432b21fe42 (patch)
tree7897614c2bfc71c0079203327f5b435b8f995d98
parentd776a2ece6c12bf8f8b6a0e65b48546ac6078765 (diff)
downloadply-72cf37bfd40dfba8404bf434bc52d0432b21fe42.tar.gz
Fixed version numbers
-rw-r--r--ANNOUNCE8
-rw-r--r--CHANGES5
-rw-r--r--README.md4
-rw-r--r--ply/__init__.py2
-rw-r--r--ply/lex.py4
-rw-r--r--ply/yacc.py4
-rw-r--r--setup.py2
7 files changed, 17 insertions, 12 deletions
diff --git a/ANNOUNCE b/ANNOUNCE
index ef5774c..15fcb41 100644
--- a/ANNOUNCE
+++ b/ANNOUNCE
@@ -1,11 +1,11 @@
-October 2, 2015
+August 31, 2016
- Announcing : PLY-3.8 (Python Lex-Yacc)
+ Announcing : PLY-3.9 (Python Lex-Yacc)
http://www.dabeaz.com/ply
-I'm pleased to announce PLY-3.7--a pure Python implementation of the
-common parsing tools lex and yacc. PLY-3.7 is a minor bug fix
+I'm pleased to announce PLY-3.9--a pure Python implementation of the
+common parsing tools lex and yacc. PLY-3.9 is a minor bug fix
release. It supports both Python 2 and Python 3.
If you are new to PLY, here are a few highlights:
diff --git a/CHANGES b/CHANGES
index e9c8348..5c2f48c 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,8 @@
+Version 3.9
+---------------------
+08/30/16: beazley
+ Minor fixes to version numbers.
+
Version 3.8
---------------------
10/02/15: beazley
diff --git a/README.md b/README.md
index d435377..402ffba 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,6 @@
-PLY (Python Lex-Yacc) Version 3.8
+PLY (Python Lex-Yacc) Version 3.9
-Copyright (C) 2001-2015,
+Copyright (C) 2001-2016
David M. Beazley (Dabeaz LLC)
All rights reserved.
diff --git a/ply/__init__.py b/ply/__init__.py
index 2461a44..6e53cdd 100644
--- a/ply/__init__.py
+++ b/ply/__init__.py
@@ -1,5 +1,5 @@
# PLY package
# Author: David Beazley (dave@dabeaz.com)
-__version__ = '3.7'
+__version__ = '3.9'
__all__ = ['lex','yacc']
diff --git a/ply/lex.py b/ply/lex.py
index 3a40f62..c45b8a0 100644
--- a/ply/lex.py
+++ b/ply/lex.py
@@ -1,7 +1,7 @@
# -----------------------------------------------------------------------------
# ply: lex.py
#
-# Copyright (C) 2001-2015,
+# Copyright (C) 2001-2016
# David M. Beazley (Dabeaz LLC)
# All rights reserved.
#
@@ -31,7 +31,7 @@
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# -----------------------------------------------------------------------------
-__version__ = '3.8'
+__version__ = '3.9'
__tabversion__ = '3.8'
import re
diff --git a/ply/yacc.py b/ply/yacc.py
index e7f36aa..36d679a 100644
--- a/ply/yacc.py
+++ b/ply/yacc.py
@@ -1,7 +1,7 @@
# -----------------------------------------------------------------------------
# ply: yacc.py
#
-# Copyright (C) 2001-2015,
+# Copyright (C) 2001-2016
# David M. Beazley (Dabeaz LLC)
# All rights reserved.
#
@@ -67,7 +67,7 @@ import inspect
import base64
import warnings
-__version__ = '3.8'
+__version__ = '3.9'
__tabversion__ = '3.8'
#-----------------------------------------------------------------------------
diff --git a/setup.py b/setup.py
index db1b748..948e2cf 100644
--- a/setup.py
+++ b/setup.py
@@ -17,7 +17,7 @@ PLY is extremely easy to use and provides very extensive error checking.
It is compatible with both Python 2 and Python 3.
""",
license="""BSD""",
- version = "3.8",
+ version = "3.9",
author = "David Beazley",
author_email = "dave@dabeaz.com",
maintainer = "David Beazley",