summaryrefslogtreecommitdiff
path: root/.ci
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-03-09 19:51:10 -0800
committerGiampaolo Rodola <g.rodola@gmail.com>2018-03-09 19:51:10 -0800
commitb578d2febfd35f80fcfa1ce1bdf18d44d21b1581 (patch)
tree5341acf84032ee89457b973d3c0fd24f332c4db4 /.ci
parentb409472c271c0f803cfa8ecc83033e508f2ae429 (diff)
downloadpsutil-b578d2febfd35f80fcfa1ce1bdf18d44d21b1581.tar.gz
Move tests out of package to top level directory (#1232)
Cleanly separates tests from the package itself. Prevents the tests being installed to site-packages. Tests are still distributed with the source distribution by MANIFEST.in. Avoids installing tests in production environments, leading to less total code in the environment.
Diffstat (limited to '.ci')
-rwxr-xr-x.ci/travis/run.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index 1501387a..6660bf53 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -20,14 +20,14 @@ python setup.py develop
# run tests (with coverage)
if [[ $PYVER == '2.7' ]] && [[ "$(uname -s)" != 'Darwin' ]]; then
- PSUTIL_TESTING=1 python -Wa -m coverage run psutil/tests/__main__.py
+ PSUTIL_TESTING=1 python -Wa -m coverage run tests/__main__.py
else
- PSUTIL_TESTING=1 python -Wa psutil/tests/__main__.py
+ PSUTIL_TESTING=1 python -Wa tests/__main__.py
fi
if [ "$PYVER" == "2.7" ] || [ "$PYVER" == "3.6" ]; then
# run mem leaks test
- PSUTIL_TESTING=1 python -Wa psutil/tests/test_memory_leaks.py
+ PSUTIL_TESTING=1 python -Wa tests/test_memory_leaks.py
# run linter (on Linux only)
if [[ "$(uname -s)" != 'Darwin' ]]; then
python -m flake8