summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-04-23 02:42:32 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-04-23 02:42:32 +0200
commitd82e725de0fa2a785db3225b4fd2a7c090681276 (patch)
tree6fc3b455ee4c4cb9eec8f0c01acb4d8ac0ed0d82
parent1cb346ceb70c4da7b1c9a717a922ed9ce5ee4175 (diff)
downloadpsutil-d82e725de0fa2a785db3225b4fd2a7c090681276.tar.gz
attempt to fix travis + osx
-rwxr-xr-x.ci/travis/run.sh8
-rw-r--r--.travis.yml27
2 files changed, 18 insertions, 17 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index 87485cdb..92c1db39 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -5,14 +5,6 @@ set -x
PYVER=`python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))'`
-# setup OSX venv
-# if [ "$(uname -s)" == 'Darwin' ]; then
-# if which pyenv > /dev/null; then
-# eval "$(pyenv init -)"
-# fi
-# pyenv activate psutil
-# fi
-
# install
python setup.py build
python setup.py develop
diff --git a/.travis.yml b/.travis.yml
index 3608c5e3..60e4cc56 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,7 +10,7 @@ matrix:
# - python: 3.5
# - python: 3.6
# - "pypy"
- - language: generic
+ - language: generic # osx + python2
os: osx
before_install:
- brew update
@@ -18,14 +18,23 @@ matrix:
- brew install python
- virtualenv env -p python
- source env/bin/activate
- # - language: generic
- # os: osx
- # env: PYVER=py27
- # - language: generic
- # os: osx
- # env: PYVER=py34
-install:
- - ./.ci/travis/install.sh
+ - language: generic # osx + python3
+ os: osx
+ before_install:
+ - brew update
+ - brew unlink python3
+ - brew install python3
+ - virtualenv env -p python3
+ - source env/bin/activate
+install: |
+ if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]]; then
+ pip install -U ipaddress unittest2 argparse mock==1.0.1
+ elif [[ $TRAVIS_PYTHON_VERSION == '2.7' ]]; then
+ pip install -U ipaddress mock
+ elif [[ $TRAVIS_PYTHON_VERSION == '3.3' ]]; then
+ pip install -U ipaddress
+ fi
+ pip install --upgrade coverage coveralls setuptools flake8
script:
- ./.ci/travis/run.sh
after_success: