summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-18 18:22:35 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-18 18:22:35 +0200
commit135ce35ad95f70b8fcc0d0769d16c8fc7ee18ad4 (patch)
tree6871cc114bfc557bc84a6318aefccba0de523dc0
parent6a79a37d6b9a2c0edc1bf695eff34b130cf92768 (diff)
downloadpsutil-135ce35ad95f70b8fcc0d0769d16c8fc7ee18ad4.tar.gz
give CREDITS to @alxchk; update HISTORY
-rw-r--r--CREDITS5
-rw-r--r--HISTORY.rst4
-rw-r--r--psutil/_psutil_sunos.c8
-rwxr-xr-xsetup.py6
4 files changed, 17 insertions, 6 deletions
diff --git a/CREDITS b/CREDITS
index 5483653a..b11a8b93 100644
--- a/CREDITS
+++ b/CREDITS
@@ -40,6 +40,7 @@ Github usernames of people to CC on github when in need of help.
- fbenkstein, Frank Benkstein
- SunOS:
- wiggin15, Arnon Yaari
+ - alxchk, Oleksii Shevchuk
Contributors
============
@@ -478,3 +479,7 @@ I: 1057
N: Gleb Smirnoff
W: https://github.com/glebius
I: 1042, 1079
+
+N: Oleksii Shevchuk
+W: https://github.com/alxchk
+I: 1077
diff --git a/HISTORY.rst b/HISTORY.rst
index b1843887..bdca8f24 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -62,6 +62,10 @@
processes.
- 1074_: [FreeBSD] sensors_battery() raises OSError in case of no battery.
- 1075_: [Windows] net_if_addrs(): inet_ntop() return value is not checked.
+- 1077_: [SunOS] net_if_addrs() shows garbage addresses on SunOS 5.10.
+ (patch by Oleksii Shevchuk)
+- 1077_: [SunOS] net_connections() does not work on SunOS 5.10. (patch by
+ Oleksii Shevchuk)
- 1079_: [FreeBSD] net_connections() didn't list locally connected sockets.
(patch by Gleb Smirnoff)
diff --git a/psutil/_psutil_sunos.c b/psutil/_psutil_sunos.c
index 53f719e4..eba71ec5 100644
--- a/psutil/_psutil_sunos.c
+++ b/psutil/_psutil_sunos.c
@@ -1078,7 +1078,7 @@ psutil_net_connections(PyObject *self, PyObject *args) {
#ifdef NEW_MIB_COMPLIANT
processed_pid = tp->tcpConnCreationProcess;
#else
- processed_pid = 0;
+ processed_pid = 0;
#endif
if (pid != -1 && processed_pid != pid)
continue;
@@ -1123,7 +1123,7 @@ psutil_net_connections(PyObject *self, PyObject *args) {
#ifdef NEW_MIB_COMPLIANT
processed_pid = tp6->tcp6ConnCreationProcess;
#else
- processed_pid = 0;
+ processed_pid = 0;
#endif
if (pid != -1 && processed_pid != pid)
continue;
@@ -1165,7 +1165,7 @@ psutil_net_connections(PyObject *self, PyObject *args) {
#ifdef NEW_MIB_COMPLIANT
processed_pid = ude->udpCreationProcess;
#else
- processed_pid = 0;
+ processed_pid = 0;
#endif
if (pid != -1 && processed_pid != pid)
continue;
@@ -1205,7 +1205,7 @@ psutil_net_connections(PyObject *self, PyObject *args) {
#ifdef NEW_MIB_COMPLIANT
processed_pid = ude6->udp6CreationProcess;
#else
- processed_pid = 0;
+ processed_pid = 0;
#endif
if (pid != -1 && processed_pid != pid)
continue;
diff --git a/setup.py b/setup.py
index 42ded9e1..cf3deb7f 100755
--- a/setup.py
+++ b/setup.py
@@ -233,10 +233,12 @@ elif LINUX:
elif SUNOS:
macros.append(("PSUTIL_SUNOS", 1))
- sources.append('psutil/arch/solaris/v10/ifaddrs.c')
ext = Extension(
'psutil._psutil_sunos',
- sources=sources + ['psutil/_psutil_sunos.c'],
+ sources=sources + [
+ 'psutil/_psutil_sunos.c',
+ 'psutil/arch/solaris/v10/ifaddrs.c',
+ ],
define_macros=macros,
libraries=['kstat', 'nsl', 'socket'])