summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-18 22:04:52 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-18 22:04:52 +0200
commitd2b306688b8ab94ef678676f09dde7aa453b6d0c (patch)
treedf54e78bf6d1b2d54c26f2de2c0856c8432f9dc0
parent822302832081b3968ed1ea97793709d263b5c1ca (diff)
downloadpsutil-d2b306688b8ab94ef678676f09dde7aa453b6d0c.tar.gz
set PSUTIL_TESTING env var for CI services
-rwxr-xr-x.ci/travis/run.sh6
-rw-r--r--appveyor.yml2
2 files changed, 4 insertions, 4 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index b8526dff..b27e6695 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -20,14 +20,14 @@ python setup.py develop
# run tests (with coverage)
if [[ $PYVER == '2.7' ]] && [[ "$(uname -s)" != 'Darwin' ]]; then
- python -Wa -m coverage run psutil/tests/__main__.py
+ PSUTIL_TESTING=1 python -Wa -m coverage run psutil/tests/__main__.py
else
- python -Wa psutil/tests/__main__.py
+ PSUTIL_TESTING=1 python -Wa psutil/tests/__main__.py
fi
if [ "$PYVER" == "2.7" ] || [ "$PYVER" == "3.6" ]; then
# run mem leaks test
- python -Wa psutil/tests/test_memory_leaks.py
+ PSUTIL_TESTING=1 python -Wa psutil/tests/test_memory_leaks.py
# run linter (on Linux only)
if [[ "$(uname -s)" != 'Darwin' ]]; then
python -Wa -m flake8
diff --git a/appveyor.yml b/appveyor.yml
index 1390f962..d4671784 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -91,7 +91,7 @@ build: off
test_script:
- "%WITH_COMPILER% %PYTHON%/python -V"
- - "%WITH_COMPILER% %PYTHON%/python psutil/tests/__main__.py"
+ - "set PSUTIL_TESTING=1 && %WITH_COMPILER% %PYTHON%/python psutil/tests/__main__.py"
after_test:
- "%WITH_COMPILER% %PYTHON%/python setup.py bdist_wheel"