summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-12-07 12:59:45 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2017-12-07 12:59:45 +0100
commit8ed14183cc72791b42249de4bd0d72da90cff41f (patch)
tree0a880fde814b7cb4f74b46009170546b4780cce5
parentc3767da76a366cabbe1c84ad9cef007ae51c400e (diff)
downloadpsutil-8ed14183cc72791b42249de4bd0d72da90cff41f.tar.gz
pre-release; also get rid of PSUTIL_DEBUG doc instructions (it's kinda useless for the user after all)
-rw-r--r--HISTORY.rst2
-rw-r--r--Makefile16
-rw-r--r--docs/index.rst27
3 files changed, 13 insertions, 32 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index a8bc3102..b28e52bb 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -3,7 +3,7 @@
5.4.2
=====
-*XXXX-XX-XX*
+*2017-12-07*
**Enhancements**
diff --git a/Makefile b/Makefile
index 7b2eca86..5e784bee 100644
--- a/Makefile
+++ b/Makefile
@@ -193,30 +193,30 @@ install-git-hooks: ## Install GIT pre-commit hook.
# --- create
-dist-source: ## Create tar.gz source distribution.
+source: ## Create tar.gz source distribution.
${MAKE} generate-manifest
$(PYTHON) setup.py sdist
-dist-wheel: ## Generate wheel.
+wheel: ## Generate wheel.
$(PYTHON) setup.py bdist_wheel
-dist-win-download-wheels: ## Download wheels hosted on appveyor.
+win-download-wheels: ## Download wheels hosted on appveyor.
$(TEST_PREFIX) $(PYTHON) scripts/internal/download_exes.py --user giampaolo --project psutil
# --- upload
-dist-upload-src: ## Upload source tarball on https://pypi.python.org/pypi/psutil.
- ${MAKE} dist-source
+upload-src: ## Upload source tarball on https://pypi.python.org/pypi/psutil.
+ ${MAKE} source
$(PYTHON) setup.py sdist upload
-dist-upload-win-wheels: ## Upload wheels in dist/* directory on PYPI.
+upload-win-wheels: ## Upload wheels in dist/* directory on PYPI.
$(PYTHON) -m twine upload dist/*.whl
# --- others
pre-release: ## Check if we're ready to produce a new release.
${MAKE} install
- ${MAKE} dist-source
+ ${MAKE} source
$(PYTHON) -c \
"from psutil import __version__ as ver; \
doc = open('docs/index.rst').read(); \
@@ -227,7 +227,7 @@ pre-release: ## Check if we're ready to produce a new release.
${MAKE} generate-manifest
git diff MANIFEST.in > /dev/null # ...otherwise 'git diff-index HEAD' will complain
$(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else sys.exit(0);"
- ${MAKE} dist-win-download-wheels
+ ${MAKE} win-download-wheels
${MAKE} sdist
release: ## Create a release (down/uploads tar.gz, wheels, git tag release).
diff --git a/docs/index.rst b/docs/index.rst
index ea2384bb..c09045f7 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -2302,29 +2302,6 @@ Constants
----
-Debug mode
-==========
-
-In case you bump into nasty errors which look like being psutil's fault you may
-want to run psutil in debug mode. psutil may (or may not) print some useful
-message on stderr before crashing with an exception
-(see `original motivation <https://github.com/giampaolo/psutil/issues/1173>`__).
-To enable debug mode on UNIX:
-
-.. code-block:: bash
-
- PSUTIL_DEBUG=1 python script.py
-
-On Windows:
-
-.. code-block:: bat
-
- set PSUTIL_DEBUG=1 && C:\python36\python.exe script.py
-
-.. versionadded:: 5.4.2
-
-----
-
Unicode
=======
@@ -2612,6 +2589,10 @@ take a look at the
Timeline
========
+- 2017-12-07:
+ `5.4.1 <https://pypi.python.org/pypi?name=psutil&version=5.4.2&:action=files>`__ -
+ `what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#542>`__ -
+ `diff <https://github.com/giampaolo/psutil/compare/release-5.4.1...release-5.4.2#files_bucket>`__
- 2017-11-08:
`5.4.1 <https://pypi.python.org/pypi?name=psutil&version=5.4.1&:action=files>`__ -
`what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#541>`__ -