summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2018-01-01 21:31:11 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2018-01-01 21:31:11 +0100
commit958b61849b48ecbad74dbb978c976a5c34c52293 (patch)
tree4cb54fcb4736ff49173f5457478d579bd6330899
parentdf3fa28142c6db03f503018cff6341ddaf5bb954 (diff)
downloadpsutil-958b61849b48ecbad74dbb978c976a5c34c52293.tar.gz
pre release
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 9ca92bb9..e3e735da 100644
--- a/Makefile
+++ b/Makefile
@@ -228,7 +228,7 @@ pre-release: ## Check if we're ready to produce a new release.
assert ver in doc, '%r not in docs/index.rst' % ver; \
assert ver in history, '%r not in HISTORY.rst' % ver; \
assert 'XXXX' not in history, 'XXXX in HISTORY.rst';"
- $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else sys.exit(0);"
+ $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else 0;"
release: ## Create a release (down/uploads tar.gz, wheels, git tag release).
${MAKE} pre-release