summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-09-10 13:44:13 +0800
committerGiampaolo Rodola <g.rodola@gmail.com>2017-09-10 13:44:13 +0800
commitb42b9bba805b93b7adda7f983dba11620206d04f (patch)
treea8b4f5ba72a2196681c920cdf1a1370c6a41f174
parentc34dac19561501a2b37262f139248552e46c338c (diff)
downloadpsutil-b42b9bba805b93b7adda7f983dba11620206d04f.tar.gz
bump up ver
-rw-r--r--Makefile8
-rw-r--r--psutil/__init__.py2
2 files changed, 6 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index f47d262c..1ed62c39 100644
--- a/Makefile
+++ b/Makefile
@@ -237,8 +237,9 @@ win-upload-exes:
# All the necessary steps before making a release.
pre-release:
- @PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes') if out else sys.exit(0);"
- ${MAKE} sdist
+ ${MAKE} generate-manifest
+ git diff MANIFEST.in > /dev/null # ...otherwise 'git diff-index HEAD' will complain
+ @PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else sys.exit(0);"
${MAKE} install
@PYTHONWARNINGS=all $(PYTHON) -c \
"from psutil import __version__ as ver; \
@@ -248,12 +249,13 @@ pre-release:
assert ver in history, '%r not in HISTORY.rst' % ver; \
assert 'XXXX' not in history, 'XXXX in HISTORY.rst';"
${MAKE} win-download-exes
+ ${MAKE} sdist
# Create a release: creates tar.gz and exes/wheels, uploads them,
# upload doc, git tag release.
release:
${MAKE} pre-release
- PYTHONWARNINGS=all $(PYTHON) -m twine upload dist/* # upload tar.gz, exes, wheels on PYPI
+ PYTHONWARNINGS=all $(PYTHON) -m twine upload dist/* # upload tar.gz and Windows wheels on PYPI
${MAKE} git-tag-release
# Print announce of new release.
diff --git a/psutil/__init__.py b/psutil/__init__.py
index 70f9bc06..ca9bc239 100644
--- a/psutil/__init__.py
+++ b/psutil/__init__.py
@@ -203,7 +203,7 @@ __all__ = [
]
__all__.extend(_psplatform.__extra__all__)
__author__ = "Giampaolo Rodola'"
-__version__ = "5.3.1"
+__version__ = "5.3.2"
version_info = tuple([int(num) for num in __version__.split('.')])
AF_LINK = _psplatform.AF_LINK
POWER_TIME_UNLIMITED = _common.POWER_TIME_UNLIMITED