summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-01-15 19:30:04 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2017-01-15 19:30:04 +0100
commit62719fa390fe58dad822a8e0c416580b5dba000e (patch)
tree6e2139f551e9734773f1fd0e5a76c4021f40a8d8
parent4121b020586123459d64cf33225bcd45a3878f79 (diff)
downloadpsutil-62719fa390fe58dad822a8e0c416580b5dba000e.tar.gz
CI integration: add python 3.6
-rw-r--r--.travis.yml1
-rw-r--r--Makefile2
-rw-r--r--appveyor.yml11
3 files changed, 13 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 17206c58..48c84a7b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,6 +8,7 @@ matrix:
- python: 3.3
- python: 3.4
- python: 3.5
+ - python: 3.6
- "pypy"
# XXX - commented because OSX builds are deadly slow
# - language: generic
diff --git a/Makefile b/Makefile
index 9224a0bb..95db068c 100644
--- a/Makefile
+++ b/Makefile
@@ -210,7 +210,7 @@ win-download-exes:
# Upload exes/wheels in dist/* directory to PYPI.
win-upload-exes:
$(PYTHON) -m twine upload dist/*.exe
- $(PYTHON) -m twine upload dist/*.wheel
+ $(PYTHON) -m twine upload dist/*.whl
# All the necessary steps before making a release.
pre-release:
diff --git a/appveyor.yml b/appveyor.yml
index 927d9cb3..4428f776 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -30,6 +30,10 @@ environment:
PYTHON_VERSION: "3.5.x"
PYTHON_ARCH: "32"
+ - PYTHON: "C:\\Python36"
+ PYTHON_VERSION: "3.6.x"
+ PYTHON_ARCH: "32"
+
# 64 bits
- PYTHON: "C:\\Python27-x64"
@@ -51,6 +55,13 @@ environment:
VS_VER: "2015"
INSTANCENAME: "SQL2012SP1"
+ - PYTHON: "C:\\Python36-x64"
+ PYTHON_VERSION: "3.6.x"
+ PYTHON_ARCH: "64"
+ ARCH: x86_64
+ VS_VER: "2015"
+ INSTANCENAME: "SQL2012SP1"
+
# Also build on a Python version not pre-installed by Appveyor.
# See: https://github.com/ogrisel/python-appveyor-demo/issues/10