summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-02-09 19:14:34 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2016-02-09 19:14:34 +0100
commit0a21199baca692d6cb3e13b1c30290b7c151b130 (patch)
tree3c3cdb590d4a90ed98c10f58e0a3d042fee07233
parenta23477c0e9cc2fb0cf4b385beefd937b61d204a9 (diff)
downloadpsutil-0a21199baca692d6cb3e13b1c30290b7c151b130.tar.gz
add new make cmd to run os specific tests
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 532bf249..248d4184 100644
--- a/Makefile
+++ b/Makefile
@@ -81,6 +81,10 @@ test-memleaks: install
test-by-name: install
@$(PYTHON) -m nose psutil/tests/*.py --nocapture -v -m $(filter-out $@,$(MAKECMDGOALS))
+# Run specific platform tests only.
+test-platform: install
+ $(PYTHON) psutil/tests/test_`python -c 'import psutil; print([x.lower() for x in ("FREEBSD", "LINUX", "NETBSD", "OPENBSD", "OSX", "SUNOS", "WINDOWS") if getattr(psutil, x)][0])'`.py
+
# Same as above but for test_memory_leaks.py script.
test-memleaks-by-name: install
@$(PYTHON) -m nose test/test_memory_leaks.py --nocapture -v -m $(filter-out $@,$(MAKECMDGOALS))