summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-02-26 10:37:13 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2016-02-26 10:37:13 +0100
commit4f2703e900855d7680df91ba24b359709f35763c (patch)
treea87fe0461a5ce27120853a8a84a63b16e072b2fe
parent4b5a524a14c2bd5cd89c1da978a64b9188828397 (diff)
downloadpsutil-4f2703e900855d7680df91ba24b359709f35763c.tar.gz
try to fix travis
-rwxr-xr-x.ci/travis/install.sh24
-rwxr-xr-x.ci/travis/run.sh3
-rw-r--r--.travis.yml4
3 files changed, 16 insertions, 15 deletions
diff --git a/.ci/travis/install.sh b/.ci/travis/install.sh
index c6774797..9fb2c42d 100755
--- a/.ci/travis/install.sh
+++ b/.ci/travis/install.sh
@@ -13,22 +13,22 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
fi
case "${PYVER}" in
- py26)
- pyenv install 2.6.9
- pyenv virtualenv 2.6.9 psutil
- ;;
+ # py26)
+ # pyenv install 2.6.9
+ # pyenv virtualenv 2.6.9 psutil
+ # ;;
py27)
pyenv install 2.7.10
pyenv virtualenv 2.7.10 psutil
;;
- py32)
- pyenv install 3.2.6
- pyenv virtualenv 3.2.6 psutil
- ;;
- py33)
- pyenv install 3.3.6
- pyenv virtualenv 3.3.6 psutil
- ;;
+ # py32)
+ # pyenv install 3.2.6
+ # pyenv virtualenv 3.2.6 psutil
+ # ;;
+ # py33)
+ # pyenv install 3.3.6
+ # pyenv virtualenv 3.3.6 psutil
+ # ;;
py34)
pyenv install 3.4.3
pyenv virtualenv 3.4.3 psutil
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index 9bb62cbf..a3ae6c25 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -10,6 +10,9 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
pyenv activate psutil
fi
+uname -a
+python -c "import sys; print(sys.version)"
+
python setup.py build
python setup.py develop
coverage run psutil/tests/runner.py --include="psutil/*" --omit="test/*,*setup*"
diff --git a/.travis.yml b/.travis.yml
index 958ae98f..9a9251cb 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,8 +1,6 @@
sudo: false
language: python
-os:
- - linux
- - osx
+cache: pip
matrix:
include:
- python: 2.6