summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-02-28 04:49:14 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2016-02-28 04:49:14 +0100
commit737360f26e5744d109b9c3e1f867e04c41b7ed37 (patch)
treea86aa849cc2324b0e17fb60eb7947e2fce58d8c9
parent3f57ee88a64233855e492b25bae7f554ee595c46 (diff)
downloadpsutil-737360f26e5744d109b9c3e1f867e04c41b7ed37.tar.gz
update doc
-rw-r--r--IDEAS3
-rw-r--r--MANIFEST.in4
-rw-r--r--README.rst3
-rw-r--r--docs/index.rst3
4 files changed, 6 insertions, 7 deletions
diff --git a/IDEAS b/IDEAS
index b8b3a17b..18c40633 100644
--- a/IDEAS
+++ b/IDEAS
@@ -43,9 +43,6 @@ FEATURES
- #604: emulate os.getloadavg() on Windows
-- (Linux) extend Process.open_files() in order to read from /proc/pid/fdinfo
- and return file position and flags/mode.
-
- scripts/taskmgr-gui.py (using tk).
- system-wide number of open file descriptors:
diff --git a/MANIFEST.in b/MANIFEST.in
index ee26657b..67280314 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -6,6 +6,7 @@ include appveyor.yml
include CREDITS
include DEVGUIDE.rst
include HISTORY.rst
+include IDEAS
include INSTALL.rst
include LICENSE
include make.bat
@@ -13,10 +14,9 @@ include Makefile
include MANIFEST.in
include README.rst
include setup.py
-include TODO
include tox.ini
recursive-exclude docs/_build *
recursive-include .ci *
recursive-include docs *
-recursive-include scripts *.py *.rst *README
recursive-include psutil *.py *.c *.h README*
+recursive-include scripts *.py
diff --git a/README.rst b/README.rst
index 64c6ceaf..2a88f934 100644
--- a/README.rst
+++ b/README.rst
@@ -254,7 +254,8 @@ Process management
pio(read_count=478001, write_count=59371, read_bytes=700416, write_bytes=69632)
>>>
>>> p.open_files()
- [popenfile(path='/home/giampaolo/svn/psutil/somefile', fd=3)]
+ [popenfile(path='/home/giampaolo/svn/psutil/setup.py', fd=3, position=0, mode='r', flags=32768),
+ popenfile(path='/var/log/monitd', fd=4, position=235542, mode='a', flags=33793)]
>>>
>>> p.connections()
[pconn(fd=115, family=<AddressFamily.AF_INET: 2>, type=<SocketType.SOCK_STREAM: 1>, laddr=('10.0.0.1', 48776), raddr=('93.186.135.91', 80), status='ESTABLISHED'),
diff --git a/docs/index.rst b/docs/index.rst
index 429e76b3..b6cf4d91 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -1223,7 +1223,8 @@ Process class
>>> f = open('file.ext', 'w')
>>> p = psutil.Process()
>>> p.open_files()
- [popenfile(path='/home/giampaolo/svn/psutil/file.ext', fd=3)]
+ [popenfile(path='/home/giampaolo/svn/psutil/setup.py', fd=3, position=0, mode='r', flags=32768),
+ popenfile(path='/var/log/monitd', fd=4, position=235542, mode='a', flags=33793)]
.. warning::
on Windows this is not fully reliable as due to some limitations of the