summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 13:43:01 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 13:43:01 +0200
commit296d1a6e1a244eeb61ccd48015079f862d1dd57d (patch)
tree81d209ce6f312194dacdc5a64ccd95679007c67b
parent8de6ee7c645eac0814db66463267610301c89cc1 (diff)
downloadpsutil-296d1a6e1a244eeb61ccd48015079f862d1dd57d.tar.gz
better way to check if there are uncommitted changes
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5f0242ef..d14d9897 100644
--- a/Makefile
+++ b/Makefile
@@ -236,7 +236,7 @@ win-upload-exes:
# All the necessary steps before making a release.
pre-release:
- git diff-index --quiet HEAD -- || echo "err: there are uncommitted changes"; exit 1
+ git diff --quiet --exit-code || echo "err: there are uncommitted changes"; exit 1
${MAKE} sdist
${MAKE} install
@PYTHONWARNINGS=all $(PYTHON) -c \