summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-13 16:49:30 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-13 16:49:30 +0200
commit337e59331e4df84eeb57528a5cc95965220aaf3d (patch)
tree9bb572f66733e77e5eed188037ae49127f229c4a
parent47379de2dde66d7aa3d64d920b5ab20998299c79 (diff)
downloadpsutil-337e59331e4df84eeb57528a5cc95965220aaf3d.tar.gz
fix windows test; also do make clean on CI services in order to show python warnings
-rwxr-xr-x.ci/travis/run.sh1
-rw-r--r--appveyor.yml1
-rwxr-xr-xpsutil/tests/test_misc.py3
-rwxr-xr-xpsutil/tests/test_windows.py2
4 files changed, 6 insertions, 1 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index 05bc60c2..b8526dff 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -14,6 +14,7 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
fi
# install psutil
+make clean
python setup.py build
python setup.py develop
diff --git a/appveyor.yml b/appveyor.yml
index 78169616..603d2e15 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -80,6 +80,7 @@ install:
- "%WITH_COMPILER% %PYTHON%/python.exe -m pip --version"
- "%WITH_COMPILER% %PYTHON%/python.exe -m pip install --upgrade --user unittest2 ipaddress pypiwin32 wmi wheel"
- "%WITH_COMPILER% %PYTHON%/python.exe -m pip freeze"
+ - make clean
- "%WITH_COMPILER% %PYTHON%/python.exe setup.py build"
- "%WITH_COMPILER% %PYTHON%/python.exe setup.py build build_ext -i"
- "%WITH_COMPILER% %PYTHON%/python.exe setup.py develop"
diff --git a/psutil/tests/test_misc.py b/psutil/tests/test_misc.py
index 0e1ce350..2cb4dbb1 100755
--- a/psutil/tests/test_misc.py
+++ b/psutil/tests/test_misc.py
@@ -603,6 +603,9 @@ class TestWrapNumbers(unittest.TestCase):
wrap_numbers.cache_clear('disk_io')
wrap_numbers.cache_clear('?!?')
+ @unittest.skipIf(
+ not psutil.disk_io_counters() or not psutil.net_io_counters(),
+ "no disks or NICs available")
def test_cache_clear_public_apis(self):
psutil.disk_io_counters()
psutil.net_io_counters()
diff --git a/psutil/tests/test_windows.py b/psutil/tests/test_windows.py
index abb208b3..c1b080cf 100755
--- a/psutil/tests/test_windows.py
+++ b/psutil/tests/test_windows.py
@@ -338,7 +338,7 @@ class TestProcess(unittest.TestCase):
if name.startswith('_') \
or name in ('terminate', 'kill', 'suspend', 'resume',
'nice', 'send_signal', 'wait', 'children',
- 'as_dict'):
+ 'as_dict', 'memory_info_ex'):
continue
else:
try: