summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 13:53:04 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 13:53:04 +0200
commit63b43b31da9c90b77258fd69be9261591cd52b70 (patch)
tree3f8bdd80f309c2e420d923688570855ce2c309fe
parentfc5b475c1b70ee3198023aa9daf26d7fc285bc36 (diff)
downloadpsutil-63b43b31da9c90b77258fd69be9261591cd52b70.tar.gz
fix make check-broken-links
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c72e4b9f..31b84d1b 100644
--- a/Makefile
+++ b/Makefile
@@ -236,7 +236,7 @@ win-upload-exes:
# All the necessary steps before making a release.
pre-release:
- @PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes') if out else sys.exit(0);"
+ @PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes') if out else sys.exit(0);"
${MAKE} sdist
${MAKE} install
@PYTHONWARNINGS=all $(PYTHON) -c \
@@ -296,4 +296,4 @@ doc:
# check whether the links mentioned in some files are valid.
check-broken-links:
- git ls-files | grep \\.rst$ | xargs PYTHONWARNINGS=all $(PYTHON) scripts/internal/check_broken_links.py
+ git ls-files | grep \\.rst$ | xargs $(PYTHON) -Wa scripts/internal/check_broken_links.py