summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 13:39:12 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 13:39:12 +0200
commit8de6ee7c645eac0814db66463267610301c89cc1 (patch)
tree4bfc52079de6beb7aaa5a2fb80fcfa751cd19063
parent75622070daeddbc5715e2c35480c2acd37695fe8 (diff)
downloadpsutil-8de6ee7c645eac0814db66463267610301c89cc1.tar.gz
exit make pre-release if there are uncommitted changes
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ac3c699f..5f0242ef 100644
--- a/Makefile
+++ b/Makefile
@@ -236,9 +236,8 @@ win-upload-exes:
# All the necessary steps before making a release.
pre-release:
+ git diff-index --quiet HEAD -- || echo "err: there are uncommitted changes"; exit 1
${MAKE} sdist
- # Make sure MANIFEST.in has no uncommitted changes.
- PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff MANIFEST.in', shell=True).strip(); sys.exit('MANIFEST.in has uncommitted changes') if out else sys.exit(0);"
${MAKE} install
@PYTHONWARNINGS=all $(PYTHON) -c \
"from psutil import __version__ as ver; \