summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 13:49:52 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 13:49:52 +0200
commitfc5b475c1b70ee3198023aa9daf26d7fc285bc36 (patch)
tree59301b5add584566bdb84951f9665306f27a0884
parent92d53d211c482fda49adf13db11dfca89cbc7a2b (diff)
downloadpsutil-fc5b475c1b70ee3198023aa9daf26d7fc285bc36.tar.gz
better way to check if there are uncommitted changes
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d1d9fcff..c72e4b9f 100644
--- a/Makefile
+++ b/Makefile
@@ -236,7 +236,7 @@ win-upload-exes:
# All the necessary steps before making a release.
pre-release:
- @PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff', shell=True).strip(); sys.exit('there are uncommitted changes') if out else sys.exit(0);"
+ @PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes') if out else sys.exit(0);"
${MAKE} sdist
${MAKE} install
@PYTHONWARNINGS=all $(PYTHON) -c \