summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-01-04 19:12:57 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2017-01-04 19:12:57 +0100
commit0be629eace44cb65a1455970dedc9e8c4dac3b5e (patch)
tree100ff5c950c031fd7c71396c074b77da272495f5
parent5ad419071e08f311a559f385e1c6e48df6176c65 (diff)
downloadpsutil-0be629eace44cb65a1455970dedc9e8c4dac3b5e.tar.gz
fix #948: cannot install psutil with PYTHONOPTIMIZE=2
-rw-r--r--HISTORY.rst8
-rw-r--r--psutil/__init__.py5
-rwxr-xr-xsetup.py2
3 files changed, 12 insertions, 3 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index 25223322..94feab8e 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -1,5 +1,13 @@
*Bug tracker at https://github.com/giampaolo/psutil/issues*
+5.0.2
+=====
+
+**Bug fixes**
+
+- 948_: cannot install psutil with PYTHONOPTIMIZE=2.
+
+
5.0.1
=====
diff --git a/psutil/__init__.py b/psutil/__init__.py
index 4abb5766..40403392 100644
--- a/psutil/__init__.py
+++ b/psutil/__init__.py
@@ -143,8 +143,8 @@ elif SUNOS:
from ._pssunos import CONN_BOUND # NOQA
from ._pssunos import CONN_IDLE # NOQA
- # This is public API and it will be retrieved from _pssunos.py
- # via sys.modules.
+ # This is public writable API which is read from _pslinux.py and
+ # _pssunos.py via sys.modules.
PROCFS_PATH = "/proc"
else: # pragma: no cover
@@ -222,6 +222,7 @@ if (int(__version__.replace('.', '')) !=
# --- exceptions
# =====================================================================
+
class Error(Exception):
"""Base exception class. All other psutil exceptions inherit
from this one.
diff --git a/setup.py b/setup.py
index 4e3b0c6b..04f6436a 100755
--- a/setup.py
+++ b/setup.py
@@ -255,7 +255,7 @@ def main():
setup(
name='psutil',
version=VERSION,
- description=__doc__.replace('\n', '').strip(),
+ description=__doc__ or ''.replace('\n', '').strip(),
long_description=get_description(),
keywords=[
'ps', 'top', 'kill', 'free', 'lsof', 'netstat', 'nice', 'tty',