summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-11-03 10:27:19 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2017-11-03 10:27:19 +0100
commit3f74e32f0c97e67e4647903df6f400c0e1491445 (patch)
tree8011d05467b92ab45d4ec91f19f19fb5f8ae147f
parenta4f00398f923bf1db2cd575af0074870138d328a (diff)
downloadpsutil-3f74e32f0c97e67e4647903df6f400c0e1491445.tar.gz
update Makefile
-rw-r--r--MANIFEST.in4
-rw-r--r--Makefile28
-rw-r--r--psutil/__init__.py2
3 files changed, 13 insertions, 21 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 59a102a5..11945017 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -41,12 +41,12 @@ include psutil/_psutil_posix.h
include psutil/_psutil_sunos.c
include psutil/_psutil_windows.c
include psutil/_pswindows.py
+include psutil/arch/aix/common.c
+include psutil/arch/aix/common.h
include psutil/arch/aix/ifaddrs.c
include psutil/arch/aix/ifaddrs.h
include psutil/arch/aix/net_connections.c
include psutil/arch/aix/net_connections.h
-include psutil/arch/aix/common.c
-include psutil/arch/aix/common.h
include psutil/arch/aix/net_kernel_structs.h
include psutil/arch/freebsd/proc_socks.c
include psutil/arch/freebsd/proc_socks.h
diff --git a/Makefile b/Makefile
index 5a860365..f3691048 100644
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,6 @@
PYTHON = python
TSCRIPT = psutil/tests/__main__.py
ARGS =
-
# List of nice-to-have dev libs.
DEPS = \
argparse \
@@ -60,7 +59,6 @@ clean:
_:
-
# Compile without installing.
build: _
# make sure setuptools is installed (needed for 'develop' / edit mode)
@@ -87,7 +85,7 @@ uninstall:
# Install PIP (only if necessary).
install-pip:
- PYTHONWARNINGS=all $(PYTHON) -c \
+ $(PYTHON) -c \
"import sys, ssl, os, pkgutil, tempfile, atexit; \
sys.exit(0) if pkgutil.find_loader('pip') else None; \
pyexc = 'from urllib.request import urlopen' if sys.version_info[0] == 3 else 'from urllib2 import urlopen'; \
@@ -159,7 +157,7 @@ test-posix:
# Run specific platform tests only.
test-platform:
${MAKE} install
- PSUTIL_TESTING=1 PYTHONWARNINGS=all $(PYTHON) psutil/tests/test_`$(PYTHON) -c 'import psutil; print([x.lower() for x in ("LINUX", "BSD", "OSX", "SUNOS", "WINDOWS") if getattr(psutil, x)][0])'`.py
+ PSUTIL_TESTING=1 PYTHONWARNINGS=all $(PYTHON) psutil/tests/test_`$(PYTHON) -c 'import psutil; print([x.lower() for x in ("LINUX", "BSD", "OSX", "SUNOS", "WINDOWS", "AIX") if getattr(psutil, x)][0])'`.py
# Memory leak tests.
test-memleaks:
@@ -218,12 +216,12 @@ install-git-hooks:
# Generate tar.gz source distribution.
sdist:
${MAKE} generate-manifest
- PYTHONWARNINGS=all $(PYTHON) setup.py sdist
+ $(PYTHON) setup.py sdist
# Upload source tarball on https://pypi.python.org/pypi/psutil.
upload-src:
${MAKE} sdist
- PYTHONWARNINGS=all $(PYTHON) setup.py sdist upload
+ $(PYTHON) setup.py sdist upload
# Download exes/wheels hosted on appveyor.
win-download-exes:
@@ -231,13 +229,13 @@ win-download-exes:
# Upload exes/wheels in dist/* directory to PYPI.
win-upload-exes:
- PYTHONWARNINGS=all $(PYTHON) -m twine upload dist/*.exe
- PYTHONWARNINGS=all $(PYTHON) -m twine upload dist/*.whl
+ $(PYTHON) -m twine upload dist/*.exe
+ $(PYTHON) -m twine upload dist/*.whl
# All the necessary steps before making a release.
pre-release:
${MAKE} install
- @PYTHONWARNINGS=all $(PYTHON) -c \
+ $(PYTHON) -c \
"from psutil import __version__ as ver; \
doc = open('docs/index.rst').read(); \
history = open('HISTORY.rst').read(); \
@@ -246,7 +244,7 @@ pre-release:
assert 'XXXX' not in history, 'XXXX in HISTORY.rst';"
${MAKE} generate-manifest
git diff MANIFEST.in > /dev/null # ...otherwise 'git diff-index HEAD' will complain
- @PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else sys.exit(0);"
+ $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else sys.exit(0);"
${MAKE} win-download-exes
${MAKE} sdist
@@ -267,11 +265,11 @@ print-timeline:
# Inspect MANIFEST.in file.
check-manifest:
- PYTHONWARNINGS=all $(PYTHON) -m check_manifest -v $(ARGS)
+ $(PYTHON) -m check_manifest -v $(ARGS)
# Generates MANIFEST.in file.
generate-manifest:
- @PYTHONWARNINGS=all $(PYTHON) scripts/internal/generate_manifest.py > MANIFEST.in
+ $(PYTHON) scripts/internal/generate_manifest.py > MANIFEST.in
# ===================================================================
# Misc
@@ -290,12 +288,6 @@ bench-oneshot-2:
${MAKE} install
PYTHONWARNINGS=all $(PYTHON) scripts/internal/bench_oneshot_2.py
-# generate a doc.zip file and manually upload it to PYPI.
-doc:
- cd docs && make html && cd _build/html/ && zip doc.zip -r .
- mv docs/_build/html/doc.zip .
- @echo "done; now manually upload doc.zip from here: https://pypi.python.org/pypi?:action=pkg_edit&name=psutil"
-
# check whether the links mentioned in some files are valid.
check-broken-links:
git ls-files | xargs $(PYTHON) -Wa scripts/internal/check_broken_links.py
diff --git a/psutil/__init__.py b/psutil/__init__.py
index 97d80940..01934ac3 100644
--- a/psutil/__init__.py
+++ b/psutil/__init__.py
@@ -212,7 +212,7 @@ __all__ = [
]
__all__.extend(_psplatform.__extra__all__)
__author__ = "Giampaolo Rodola'"
-__version__ = "5.4.0"
+__version__ = "5.4.1"
version_info = tuple([int(num) for num in __version__.split('.')])
AF_LINK = _psplatform.AF_LINK
POWER_TIME_UNLIMITED = _common.POWER_TIME_UNLIMITED