summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-11-08 14:15:15 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2017-11-08 14:15:15 +0100
commit810498c36895e03a1b4e947659a2b30d8188557b (patch)
treee185585f3d3ff806ed2cfca27055116d4c165ad8
parentc95f317d586bbd4313f705c5618f0fd5477cb210 (diff)
downloadpsutil-810498c36895e03a1b4e947659a2b30d8188557b.tar.gz
#1053: drop python 3.3 support
-rw-r--r--.travis.yml1
-rw-r--r--HISTORY.rst2
-rw-r--r--appveyor.yml8
-rwxr-xr-xscripts/internal/download_exes.py2
-rwxr-xr-xscripts/internal/winmake.py4
-rwxr-xr-xsetup.py1
6 files changed, 5 insertions, 13 deletions
diff --git a/.travis.yml b/.travis.yml
index 0f191938..e08b3a39 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,7 +5,6 @@ matrix:
include:
- python: 2.6
- python: 2.7
- - python: 3.3
- python: 3.4
- python: 3.5
- python: 3.6
diff --git a/HISTORY.rst b/HISTORY.rst
index db11d4ab..980be863 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -9,6 +9,8 @@
- 1164_: [AIX] add support for Process.num_ctx_switches(). (patch by Arnon
Yaari)
+- 1053_: abandon Python 3.3 support (psutil still works but it's no longer
+ tested).
**Bug fixes**
diff --git a/appveyor.yml b/appveyor.yml
index b1867724..5fb1d7a3 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -20,10 +20,6 @@ environment:
PYTHON_VERSION: "2.7.x"
PYTHON_ARCH: "32"
- - PYTHON: "C:\\Python33"
- PYTHON_VERSION: "3.3.x"
- PYTHON_ARCH: "32"
-
- PYTHON: "C:\\Python34"
PYTHON_VERSION: "3.4.x"
PYTHON_ARCH: "32"
@@ -42,10 +38,6 @@ environment:
PYTHON_VERSION: "2.7.x"
PYTHON_ARCH: "64"
- - PYTHON: "C:\\Python33-x64"
- PYTHON_VERSION: "3.3.x"
- PYTHON_ARCH: "64"
-
- PYTHON: "C:\\Python34-x64"
PYTHON_VERSION: "3.4.x"
PYTHON_ARCH: "64"
diff --git a/scripts/internal/download_exes.py b/scripts/internal/download_exes.py
index 5c2d70ac..1b004428 100755
--- a/scripts/internal/download_exes.py
+++ b/scripts/internal/download_exes.py
@@ -25,7 +25,7 @@ from psutil import __version__ as PSUTIL_VERSION
BASE_URL = 'https://ci.appveyor.com/api'
-PY_VERSIONS = ['2.7', '3.3', '3.4', '3.5', '3.6']
+PY_VERSIONS = ['2.7', '3.4', '3.5', '3.6']
TIMEOUT = 30
COLORS = True
diff --git a/scripts/internal/winmake.py b/scripts/internal/winmake.py
index 5b2bea98..a09e2896 100755
--- a/scripts/internal/winmake.py
+++ b/scripts/internal/winmake.py
@@ -448,8 +448,8 @@ def set_python(s):
# try to look for a python installation
orig = s
s = s.replace('.', '')
- vers = ('26', '27', '33', '34', '35', '36', '37',
- '26-64', '27-64', '33-64', '34-64', '35-64', '36-64', '37-64')
+ vers = ('26', '27', '34', '35', '36', '37',
+ '26-64', '27-64', '34-64', '35-64', '36-64', '37-64')
for v in vers:
if s == v:
path = 'C:\\python%s\python.exe' % s
diff --git a/setup.py b/setup.py
index a170d2de..1625a3eb 100755
--- a/setup.py
+++ b/setup.py
@@ -318,7 +318,6 @@ def main():
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',