summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2021-10-22 18:48:34 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2021-10-22 18:48:34 +0200
commitfecdc867e37fff0cf3397c1de0c9cd5e0dbe3de3 (patch)
tree2b568a9155a85cdc773b188a60615a501dcdf85d
parentb13cca3a0eb3963833201d179d249f4dcc310908 (diff)
downloadpsutil-fecdc867e37fff0cf3397c1de0c9cd5e0dbe3de3.tar.gz
try to update CI conf
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
-rw-r--r--.github/workflows/build.yml6
-rwxr-xr-xscripts/internal/print_wheels.py2
2 files changed, 4 insertions, 4 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index 8a6eae0a..0e90e2da 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -29,8 +29,7 @@ jobs:
matrix:
# os: [ubuntu-latest, macos-latest, windows-latest]
os: [ubuntu-latest, macos-latest]
- include:
- - {name: Linux, python: '3.9', os: ubuntu-latest}
+ python-version: ['2.7', '3.7', '3.8', '3.9', '3.10']
env:
CIBW_TEST_COMMAND:
PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_TESTING=1 PSUTIL_DEBUG=1 python {project}/psutil/tests/runner.py &&
@@ -86,7 +85,7 @@ jobs:
- name: Run tests
id: test
- uses: vmactions/freebsd-vm@v0.1.4
+ uses: vmactions/freebsd-vm@v0.1.5
with:
usesh: true
prepare: pkg install -y gcc python3
@@ -97,6 +96,7 @@ jobs:
PYTHONWARNINGS=always \
PSUTIL_TESTING=1 \
PSUTIL_DEBUG=1
+ freebsd-version
python3 -m pip install --user setuptools
python3 setup.py install
python3 psutil/tests/runner.py
diff --git a/scripts/internal/print_wheels.py b/scripts/internal/print_wheels.py
index c2b8d36b..4d31bf1b 100755
--- a/scripts/internal/print_wheels.py
+++ b/scripts/internal/print_wheels.py
@@ -74,7 +74,7 @@ def main():
tot_files = 0
tot_size = 0
- templ = "%-54s %7s %7s %7s"
+ templ = "%-74s %7s %7s %7s"
for platf, wheels in groups.items():
ppn = "%s (total = %s)" % (platf, len(wheels))
s = templ % (ppn, "size", "arch", "pyver")