summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-05-13 16:45:11 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2020-05-13 16:45:11 +0200
commit18e88998a5f25ab9335afbaacfa3db46287bfa1f (patch)
treee218fc88a5ce98fbfdafa9b9dbd7a84bb83c7862
parent9c0ba43950861afd9fc9ff184bbb1f4fe32079d8 (diff)
downloadpsutil-18e88998a5f25ab9335afbaacfa3db46287bfa1f.tar.gz
rename memleaks script
-rwxr-xr-x.ci/travis/run.sh2
-rw-r--r--.flake82
-rw-r--r--MANIFEST.in2
-rw-r--r--Makefile2
-rwxr-xr-xpsutil/tests/runner.py2
-rwxr-xr-xpsutil/tests/test_memleaks.py (renamed from psutil/tests/test_memory_leaks.py)0
-rwxr-xr-xscripts/internal/winmake.py2
7 files changed, 6 insertions, 6 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index 879e78a6..ae593df5 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -27,7 +27,7 @@ fi
if [ "$PYVER" == "2.7" ] || [ "$PYVER" == "3.6" ]; then
# run mem leaks test
- PSUTIL_TESTING=1 python -Wa psutil/tests/test_memory_leaks.py
+ PSUTIL_TESTING=1 python -Wa psutil/tests/test_memleaks.py
# run linter (on Linux only)
if [[ "$(uname -s)" != 'Darwin' ]]; then
make lint PYTHON=python
diff --git a/.flake8 b/.flake8
index f06f8344..e125df09 100644
--- a/.flake8
+++ b/.flake8
@@ -12,4 +12,4 @@ per-file-ignores =
setup.py:T001
scripts/*:T001
psutil/tests/runner.py:T001
- psutil/tests/test_memory_leaks.py:T001
+ psutil/tests/test_memleaks.py:T001
diff --git a/MANIFEST.in b/MANIFEST.in
index d0d75240..2b51a545 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -96,7 +96,7 @@ include psutil/tests/test_bsd.py
include psutil/tests/test_connections.py
include psutil/tests/test_contracts.py
include psutil/tests/test_linux.py
-include psutil/tests/test_memory_leaks.py
+include psutil/tests/test_memleaks.py
include psutil/tests/test_misc.py
include psutil/tests/test_osx.py
include psutil/tests/test_posix.py
diff --git a/Makefile b/Makefile
index 2b2a98ef..29afe2de 100644
--- a/Makefile
+++ b/Makefile
@@ -162,7 +162,7 @@ test-platform: ## Run specific platform tests only.
test-memleaks: ## Memory leak tests.
${MAKE} build
- $(TEST_PREFIX) $(PYTHON) $(TSCRIPT) $(ARGS) psutil/tests/test_memory_leaks.py
+ $(TEST_PREFIX) $(PYTHON) $(TSCRIPT) $(ARGS) psutil/tests/test_memleaks.py
test-by-name: ## e.g. make test-by-name ARGS=psutil.tests.test_system.TestSystemAPIs
${MAKE} build
diff --git a/psutil/tests/runner.py b/psutil/tests/runner.py
index 97139fbc..536bb9e4 100755
--- a/psutil/tests/runner.py
+++ b/psutil/tests/runner.py
@@ -71,7 +71,7 @@ def cprint(msg, color, bold=False, file=None):
class TestLoader:
testdir = HERE
- skip_files = ['test_memory_leaks.py']
+ skip_files = ['test_memleaks.py']
if "WHEELHOUSE_UPLOADER_USERNAME" in os.environ:
skip_files.extend(['test_osx.py', 'test_linux.py', 'test_posix.py'])
diff --git a/psutil/tests/test_memory_leaks.py b/psutil/tests/test_memleaks.py
index cab91428..cab91428 100755
--- a/psutil/tests/test_memory_leaks.py
+++ b/psutil/tests/test_memleaks.py
diff --git a/scripts/internal/winmake.py b/scripts/internal/winmake.py
index a83aed3e..8fc3a984 100755
--- a/scripts/internal/winmake.py
+++ b/scripts/internal/winmake.py
@@ -488,7 +488,7 @@ def test_failed():
def test_memleaks():
"""Run memory leaks tests"""
build()
- sh("%s psutil\\tests\\test_memory_leaks.py" % PYTHON)
+ sh("%s psutil\\tests\\test_memleaks.py" % PYTHON)
def install_git_hooks():