summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-02-03 15:33:31 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2016-02-03 15:33:31 +0100
commit2985675b43aebd5f34c7f181dc88943c4af1c65a (patch)
treedbcd9a97d4ac5c17536d49ac1e250c1d4a099936
parent853303b66d78cab10cdd01529fe92afefad57cd8 (diff)
downloadpsutil-2985675b43aebd5f34c7f181dc88943c4af1c65a.tar.gz
update CREDITS
-rw-r--r--CREDITS4
-rw-r--r--HISTORY.rst1
-rw-r--r--README.rst1
-rw-r--r--setup.py2
4 files changed, 7 insertions, 1 deletions
diff --git a/CREDITS b/CREDITS
index 7052fe3b..0636ea6e 100644
--- a/CREDITS
+++ b/CREDITS
@@ -367,3 +367,7 @@ N: Sebastian-Gabriel Brestin
C: Romania
E: sebastianbrestin@gmail.com
I: 704
+
+N: Timmy Konick
+W: https://github.com/tijko
+I: 751
diff --git a/HISTORY.rst b/HISTORY.rst
index e6d5d23a..27b628b9 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -18,6 +18,7 @@ Bug tracker at https://github.com/giampaolo/psutil/issues
different cmdline() and cwd() could return a wrong result or incorrectly
report an AccessDenied error.
- #741: [OpenBSD] psutil does not compile on mips64.
+- #751: [Linux] fixed call to Py_DECREF on possible Null object.
3.4.2 - 2016-01-20
diff --git a/README.rst b/README.rst
index 748780cc..81fe9bb3 100644
--- a/README.rst
+++ b/README.rst
@@ -247,6 +247,7 @@ Process management
pmmap_grouped(path='[heap]', rss=32768, size=139264, pss=32768, shared_clean=0, shared_dirty=0, private_clean=0, private_dirty=32768, referenced=32768, anonymous=32768, swap=0),
pmmap_grouped(path='[stack]', rss=2465792, size=2494464, pss=2465792, shared_clean=0, shared_dirty=0, private_clean=0, private_dirty=2465792, referenced=2277376, anonymous=2465792, swap=0),
...]
+ >>>
>>> p.io_counters()
pio(read_count=478001, write_count=59371, read_bytes=700416, write_bytes=69632)
>>>
diff --git a/setup.py b/setup.py
index 079f889c..d5c66e81 100644
--- a/setup.py
+++ b/setup.py
@@ -118,7 +118,7 @@ elif _common.OSX:
sources=[
'psutil/_psutil_osx.c',
'psutil/_psutil_common.c',
- 'psutil/arch/osx/process_info.c'
+ 'psutil/arch/osx/process_info.c',
],
define_macros=[VERSION_MACRO],
extra_link_args=[