summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-02-15 18:17:37 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2020-02-15 18:17:37 +0100
commit3424a1a6f8f91292eca6373ba0cd3fb5170c1648 (patch)
tree197b097c817ec522eb71ad6bb6f482cb24f994b5
parenta8c9e878d5b43cbb729187ae6e1304eebd09b8dc (diff)
downloadpsutil-3424a1a6f8f91292eca6373ba0cd3fb5170c1648.tar.gz
point all shebangs to python 3
-rwxr-xr-xpsutil/tests/__main__.py2
-rwxr-xr-xpsutil/tests/runner.py2
-rwxr-xr-xpsutil/tests/test_aix.py2
-rwxr-xr-xpsutil/tests/test_bsd.py2
-rwxr-xr-xpsutil/tests/test_connections.py2
-rwxr-xr-xpsutil/tests/test_contracts.py2
-rwxr-xr-xpsutil/tests/test_linux.py2
-rwxr-xr-xpsutil/tests/test_memory_leaks.py2
-rwxr-xr-xpsutil/tests/test_misc.py2
-rwxr-xr-xpsutil/tests/test_osx.py2
-rwxr-xr-xpsutil/tests/test_posix.py2
-rwxr-xr-xpsutil/tests/test_process.py2
-rwxr-xr-xpsutil/tests/test_sunos.py2
-rwxr-xr-xpsutil/tests/test_system.py2
-rwxr-xr-x[-rw-r--r--]psutil/tests/test_unicode.py2
-rwxr-xr-xpsutil/tests/test_windows.py2
-rwxr-xr-xscripts/battery.py2
-rwxr-xr-xscripts/cpu_distribution.py2
-rwxr-xr-xscripts/disk_usage.py2
-rwxr-xr-xscripts/fans.py2
-rwxr-xr-xscripts/free.py2
-rwxr-xr-xscripts/ifconfig.py2
-rwxr-xr-xscripts/internal/bench_oneshot.py2
-rwxr-xr-x[-rw-r--r--]scripts/internal/bench_oneshot_2.py2
-rwxr-xr-xscripts/internal/check_broken_links.py4
-rwxr-xr-x[-rw-r--r--]scripts/internal/fix_flake8.py2
-rwxr-xr-xscripts/internal/generate_manifest.py2
-rwxr-xr-x[-rw-r--r--]scripts/internal/print_access_denied.py2
-rwxr-xr-xscripts/internal/print_announce.py2
-rwxr-xr-x[-rw-r--r--]scripts/internal/print_api_speed.py2
-rwxr-xr-x[-rw-r--r--]scripts/internal/print_timeline.py2
-rwxr-xr-xscripts/internal/purge_installation.py2
-rwxr-xr-xscripts/internal/win_download_wheels.py2
-rwxr-xr-xscripts/internal/winmake.py2
-rwxr-xr-xscripts/iotop.py2
-rwxr-xr-xscripts/killall.py2
-rwxr-xr-xscripts/meminfo.py2
-rwxr-xr-xscripts/netstat.py2
-rwxr-xr-xscripts/nettop.py2
-rwxr-xr-xscripts/pidof.py2
-rwxr-xr-xscripts/pmap.py2
-rwxr-xr-xscripts/procinfo.py2
-rwxr-xr-xscripts/procsmem.py2
-rwxr-xr-xscripts/ps.py2
-rwxr-xr-xscripts/pstree.py2
-rwxr-xr-xscripts/sensors.py2
-rwxr-xr-xscripts/temperatures.py2
-rwxr-xr-xscripts/top.py2
-rwxr-xr-xscripts/who.py2
-rwxr-xr-xscripts/winservices.py2
-rwxr-xr-xsetup.py2
51 files changed, 52 insertions, 52 deletions
diff --git a/psutil/tests/__main__.py b/psutil/tests/__main__.py
index 68710d44..9dd0804c 100755
--- a/psutil/tests/__main__.py
+++ b/psutil/tests/__main__.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/runner.py b/psutil/tests/runner.py
index 4c3359dd..589117b8 100755
--- a/psutil/tests/runner.py
+++ b/psutil/tests/runner.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_aix.py b/psutil/tests/test_aix.py
index 1757e3e5..7171232e 100755
--- a/psutil/tests/test_aix.py
+++ b/psutil/tests/test_aix.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'
# Copyright (c) 2017, Arnon Yaari
diff --git a/psutil/tests/test_bsd.py b/psutil/tests/test_bsd.py
index e525e667..899875d0 100755
--- a/psutil/tests/test_bsd.py
+++ b/psutil/tests/test_bsd.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_connections.py b/psutil/tests/test_connections.py
index c7fe1992..972ac9d5 100755
--- a/psutil/tests/test_connections.py
+++ b/psutil/tests/test_connections.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_contracts.py b/psutil/tests/test_contracts.py
index 5e258b30..01ebe141 100755
--- a/psutil/tests/test_contracts.py
+++ b/psutil/tests/test_contracts.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_linux.py b/psutil/tests/test_linux.py
index 97946a0b..e51f8bd5 100755
--- a/psutil/tests/test_linux.py
+++ b/psutil/tests/test_linux.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_memory_leaks.py b/psutil/tests/test_memory_leaks.py
index 31a632a4..f9cad70f 100755
--- a/psutil/tests/test_memory_leaks.py
+++ b/psutil/tests/test_memory_leaks.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_misc.py b/psutil/tests/test_misc.py
index 616a3654..c20cd941 100755
--- a/psutil/tests/test_misc.py
+++ b/psutil/tests/test_misc.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# -*- coding: utf-8 -*-
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
diff --git a/psutil/tests/test_osx.py b/psutil/tests/test_osx.py
index 723b255e..e4e77f93 100755
--- a/psutil/tests/test_osx.py
+++ b/psutil/tests/test_osx.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_posix.py b/psutil/tests/test_posix.py
index e405393b..83c1b22b 100755
--- a/psutil/tests/test_posix.py
+++ b/psutil/tests/test_posix.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# -*- coding: utf-8 -*-
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
diff --git a/psutil/tests/test_process.py b/psutil/tests/test_process.py
index e5ff6e45..987bdf38 100755
--- a/psutil/tests/test_process.py
+++ b/psutil/tests/test_process.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_sunos.py b/psutil/tests/test_sunos.py
index 94405d41..e3beb625 100755
--- a/psutil/tests/test_sunos.py
+++ b/psutil/tests/test_sunos.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_system.py b/psutil/tests/test_system.py
index 0d3f4375..c32e8a73 100755
--- a/psutil/tests/test_system.py
+++ b/psutil/tests/test_system.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/psutil/tests/test_unicode.py b/psutil/tests/test_unicode.py
index 81a28807..ac2d4f69 100644..100755
--- a/psutil/tests/test_unicode.py
+++ b/psutil/tests/test_unicode.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# -*- coding: utf-8 -*-
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
diff --git a/psutil/tests/test_windows.py b/psutil/tests/test_windows.py
index 934ea847..f68885d0 100755
--- a/psutil/tests/test_windows.py
+++ b/psutil/tests/test_windows.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# -*- coding: UTF-8 -*
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
diff --git a/scripts/battery.py b/scripts/battery.py
index abbad878..0da2b958 100755
--- a/scripts/battery.py
+++ b/scripts/battery.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/cpu_distribution.py b/scripts/cpu_distribution.py
index 839d31df..08997797 100755
--- a/scripts/cpu_distribution.py
+++ b/scripts/cpu_distribution.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/disk_usage.py b/scripts/disk_usage.py
index 1860401f..901dbf8c 100755
--- a/scripts/disk_usage.py
+++ b/scripts/disk_usage.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/fans.py b/scripts/fans.py
index 7a0ccf91..179af631 100755
--- a/scripts/fans.py
+++ b/scripts/fans.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/free.py b/scripts/free.py
index 82e962ff..000323c5 100755
--- a/scripts/free.py
+++ b/scripts/free.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/ifconfig.py b/scripts/ifconfig.py
index ad62a44f..cfd02f0d 100755
--- a/scripts/ifconfig.py
+++ b/scripts/ifconfig.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/bench_oneshot.py b/scripts/internal/bench_oneshot.py
index 28ad4bac..436bdd6b 100755
--- a/scripts/internal/bench_oneshot.py
+++ b/scripts/internal/bench_oneshot.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/bench_oneshot_2.py b/scripts/internal/bench_oneshot_2.py
index becf930c..3867391b 100644..100755
--- a/scripts/internal/bench_oneshot_2.py
+++ b/scripts/internal/bench_oneshot_2.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/check_broken_links.py b/scripts/internal/check_broken_links.py
index 73134818..1a076116 100755
--- a/scripts/internal/check_broken_links.py
+++ b/scripts/internal/check_broken_links.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola', Himanshu Shekhar.
# All rights reserved. Use of this source code is governed by a
@@ -175,7 +175,7 @@ def get_urls(fname):
return parse_c(fname)
else:
with open(fname, 'rt', errors='ignore') as f:
- if f.readline().strip().startswith('#!/usr/bin/env python'):
+ if f.readline().strip().startswith('#!/usr/bin/env python3'):
return parse_py(fname)
return parse_generic(fname)
diff --git a/scripts/internal/fix_flake8.py b/scripts/internal/fix_flake8.py
index 5aa84db5..7cde608b 100644..100755
--- a/scripts/internal/fix_flake8.py
+++ b/scripts/internal/fix_flake8.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/generate_manifest.py b/scripts/internal/generate_manifest.py
index f6cf0eaa..c0be6d99 100755
--- a/scripts/internal/generate_manifest.py
+++ b/scripts/internal/generate_manifest.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009 Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/print_access_denied.py b/scripts/internal/print_access_denied.py
index 9123ba6d..81d192f0 100644..100755
--- a/scripts/internal/print_access_denied.py
+++ b/scripts/internal/print_access_denied.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/print_announce.py b/scripts/internal/print_announce.py
index 7fbe74f3..9569c367 100755
--- a/scripts/internal/print_announce.py
+++ b/scripts/internal/print_announce.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009 Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/print_api_speed.py b/scripts/internal/print_api_speed.py
index 85d1cfc5..e39a1baa 100644..100755
--- a/scripts/internal/print_api_speed.py
+++ b/scripts/internal/print_api_speed.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/print_timeline.py b/scripts/internal/print_timeline.py
index 9bf6e9d1..64608b26 100644..100755
--- a/scripts/internal/print_timeline.py
+++ b/scripts/internal/print_timeline.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009 Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/purge_installation.py b/scripts/internal/purge_installation.py
index d9301719..50c00463 100755
--- a/scripts/internal/purge_installation.py
+++ b/scripts/internal/purge_installation.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009 Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/win_download_wheels.py b/scripts/internal/win_download_wheels.py
index 0cb37afe..3720dd96 100755
--- a/scripts/internal/win_download_wheels.py
+++ b/scripts/internal/win_download_wheels.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009 Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/internal/winmake.py b/scripts/internal/winmake.py
index fe0a73dc..aba3595c 100755
--- a/scripts/internal/winmake.py
+++ b/scripts/internal/winmake.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009 Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/iotop.py b/scripts/iotop.py
index 6a5d3fa9..c3afd071 100755
--- a/scripts/iotop.py
+++ b/scripts/iotop.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/killall.py b/scripts/killall.py
index f9cc9201..7bbcd75a 100755
--- a/scripts/killall.py
+++ b/scripts/killall.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/meminfo.py b/scripts/meminfo.py
index 0b15ff2b..550fcd01 100755
--- a/scripts/meminfo.py
+++ b/scripts/meminfo.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/netstat.py b/scripts/netstat.py
index af56d03d..fe3bfe40 100755
--- a/scripts/netstat.py
+++ b/scripts/netstat.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/nettop.py b/scripts/nettop.py
index 45b8879f..ce647c9d 100755
--- a/scripts/nettop.py
+++ b/scripts/nettop.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
#
# $Id: iotop.py 1160 2011-10-14 18:50:36Z g.rodola@gmail.com $
#
diff --git a/scripts/pidof.py b/scripts/pidof.py
index c1042f4f..ee18aae4 100755
--- a/scripts/pidof.py
+++ b/scripts/pidof.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola', karthikrev. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/pmap.py b/scripts/pmap.py
index 300f23e9..5f7246a1 100755
--- a/scripts/pmap.py
+++ b/scripts/pmap.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/procinfo.py b/scripts/procinfo.py
index 161b5057..01974513 100755
--- a/scripts/procinfo.py
+++ b/scripts/procinfo.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/procsmem.py b/scripts/procsmem.py
index 4f8b4c84..259d79d4 100755
--- a/scripts/procsmem.py
+++ b/scripts/procsmem.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/ps.py b/scripts/ps.py
index 8467cca6..540c032a 100755
--- a/scripts/ps.py
+++ b/scripts/ps.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/pstree.py b/scripts/pstree.py
index 8e4c9f95..0005e4a1 100755
--- a/scripts/pstree.py
+++ b/scripts/pstree.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/sensors.py b/scripts/sensors.py
index bbf3ac90..726af3d2 100755
--- a/scripts/sensors.py
+++ b/scripts/sensors.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# -*- coding: utf-8 -*-
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
diff --git a/scripts/temperatures.py b/scripts/temperatures.py
index 15b9156b..e83df440 100755
--- a/scripts/temperatures.py
+++ b/scripts/temperatures.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# -*- coding: utf-8 -*-
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
diff --git a/scripts/top.py b/scripts/top.py
index 69890e27..0b17471d 100755
--- a/scripts/top.py
+++ b/scripts/top.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/who.py b/scripts/who.py
index 748d936c..c2299eb0 100755
--- a/scripts/who.py
+++ b/scripts/who.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/scripts/winservices.py b/scripts/winservices.py
index 67724835..8792f752 100755
--- a/scripts/winservices.py
+++ b/scripts/winservices.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009, Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
diff --git a/setup.py b/setup.py
index 76c4ddba..6504d248 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2009 Giampaolo Rodola'. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be