summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-11-06 22:25:46 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2020-11-06 22:25:46 +0100
commit5b21fe2f9f75c2d9d554f3730c866da08791c40b (patch)
treea862d5ab7f2d0a73a227624c915fff2146643962
parent6443e1d0864efda9c404c049e91df0882a69066c (diff)
downloadpsutil-5b21fe2f9f75c2d9d554f3730c866da08791c40b.tar.gz
test-27
-rw-r--r--.github/workflows/build_wheel.yml16
1 files changed, 8 insertions, 8 deletions
diff --git a/.github/workflows/build_wheel.yml b/.github/workflows/build_wheel.yml
index cfbb801c..6ec80dba 100644
--- a/.github/workflows/build_wheel.yml
+++ b/.github/workflows/build_wheel.yml
@@ -25,9 +25,9 @@ jobs:
python-version: 3.9
- name: (Windows) install Visual C++ for Python 2.7
- if: startsWith(matrix.os, 'windows')
- run: |
- choco install vcpython27 -f -y
+ - if: matrix.os == 'windows-latest'
+ run: |
+ choco install vcpython27 -f -y
- name: Build wheels
run: |
@@ -41,11 +41,11 @@ jobs:
path: wheelhouse
- name: Create tar.gz
- if: startsWith(matrix.os, 'ubuntu')
- run: |
- make generate-manifest
- python setup.py sdist
- mv dist/psutil*.tar.gz wheelhouse/
+ - if: matrix.os == 'ubuntu-latest'
+ run: |
+ make generate-manifest
+ python setup.py sdist
+ mv dist/psutil*.tar.gz wheelhouse/
- name: Print hashes
run: python scripts/internal/md5sum.py wheelhouse/*