summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-09-04 22:15:06 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-09-04 22:15:06 +0200
commit9f9a82d02c901f62512236b44edb050f84cbe5b6 (patch)
tree27c4a8b672290a54c16e9f147d17f874a7fa5079
parent274dd47958c9d6bf306e3cff1d3a51e11c3970f0 (diff)
downloadpsutil-9f9a82d02c901f62512236b44edb050f84cbe5b6.tar.gz
-rw-r--r--HISTORY.rst18
-rw-r--r--Makefile7
-rwxr-xr-xpsutil/tests/test_contracts.py2
3 files changed, 13 insertions, 14 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index 1a7f553d..7767c08a 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -1,18 +1,18 @@
*Bug tracker at https://github.com/giampaolo/psutil/issues*
-5.9.2 (IN DEVELOPMENT)
-======================
+5.9.2
+=====
-XXXX-XX-XX
+2022-09-04
**Bug fixes**
-- 2093_, [FreeBSD]: `pids()`_ may fail with ENOMEM. Dynamically increase
- the ``malloc()`` buffer size until it's big enough.
-- 2095_, [Linux]: `net_if_stats()`_ returns incorrect interface speed for 100GbE
- network cards.
-- 2113_, [FreeBSD]: `virtual_memory()`_ may raise ENOMEM due to missing
- ``#include <sys/param.h>`` directive. (patch by Peter Jeremy)
+- 2093_, [FreeBSD], **[critical]**: `pids()`_ may fail with ENOMEM. Dynamically
+ increase the ``malloc()`` buffer size until it's big enough.
+- 2095_, [Linux]: `net_if_stats()`_ returns incorrect interface speed for
+ 100GbE network cards.
+- 2113_, [FreeBSD], **[critical]**: `virtual_memory()`_ may raise ENOMEM due to
+ missing ``#include <sys/param.h>`` directive. (patch by Peter Jeremy)
- 2128_, [NetBSD]: `swap_memory()`_ was miscalculated. (patch by Thomas Klausner)
5.9.1
diff --git a/Makefile b/Makefile
index 4bcea213..05ca5655 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@ TSCRIPT = psutil/tests/runner.py
# Internal.
DEPS = \
- git+https://github.com/PyCQA/autoflake.git@refs/pull/107/head \
+ git+https://github.com/PyCQA/autoflake.git \
autopep8 \
check-manifest \
concurrencytest \
@@ -270,8 +270,8 @@ check-sdist: ## Create source distribution and checks its sanity (MANIFEST)
${MAKE} clean
$(PYTHON) -m virtualenv --clear --no-wheel --quiet build/venv
PYTHONWARNINGS=all $(PYTHON) setup.py sdist
- build/venv/bin/python -m pip install -v --isolated --quiet dist/*.tar.gz
- build/venv/bin/python -c "import os; os.chdir('build/venv'); import psutil"
+ build/venv/local/bin/python -m pip install -v --isolated --quiet dist/*.tar.gz
+ build/venv/local/bin/python -c "import os; os.chdir('build/venv'); import psutil"
pre-release: ## Check if we're ready to produce a new release.
${MAKE} check-sdist
@@ -293,7 +293,6 @@ pre-release: ## Check if we're ready to produce a new release.
assert 'XXXX' not in history, 'XXXX in HISTORY.rst';"
release: ## Create a release (down/uploads tar.gz, wheels, git tag release).
- $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff --quiet && git diff --cached --quiet', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else 0 ;"
$(PYTHON) -m twine upload dist/* # upload tar.gz and Windows wheels on PyPI
${MAKE} git-tag-release
diff --git a/psutil/tests/test_contracts.py b/psutil/tests/test_contracts.py
index 5c927d68..0d900669 100755
--- a/psutil/tests/test_contracts.py
+++ b/psutil/tests/test_contracts.py
@@ -680,7 +680,7 @@ class TestFetchAllProcesses(PsutilTestCase):
for fname in nt._fields:
value = getattr(nt, fname)
if fname == 'path':
- if not value.startswith('['):
+ if not value.startswith(("[", "anon_inode:")):
assert os.path.isabs(nt.path), nt.path
# commented as on Linux we might get
# '/foo/bar (deleted)'