summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-06-20 17:53:14 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2020-06-20 17:53:14 +0200
commitcbd61676b3818aeeebfb5b71309e73a8717ede6f (patch)
treededd70d65e88410070ee9b4b0f6a28447818f0e8
parent2a44280b2e4a6bcb3ccc0b622acea3305807e175 (diff)
downloadpsutil-cbd61676b3818aeeebfb5b71309e73a8717ede6f.tar.gz
fix PYTHONWARNINGS
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 25f1dc1a..be92b744 100644
--- a/Makefile
+++ b/Makefile
@@ -37,7 +37,7 @@ BUILD_OPTS = `$(PYTHON) -c \
# In not in a virtualenv, add --user options for install commands.
INSTALL_OPTS = `$(PYTHON) -c \
"import sys; print('' if hasattr(sys, 'real_prefix') else '--user')"`
-TEST_PREFIX = PYTHONWARNINGS=all PSUTIL_TESTING=1 PSUTIL_DEBUG=1
+TEST_PREFIX = PYTHONWARNINGS=always PSUTIL_TESTING=1 PSUTIL_DEBUG=1
all: test