summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-02-18 00:29:03 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2020-02-18 00:29:03 +0100
commit793148fee9c46c3df8b7ca941d6c73d5c61bc3a8 (patch)
treefcff645ded7d59af4258707942434837aad7ad0d
parent9069e2534efa1134153b75de4ae8be32f0000778 (diff)
downloadpsutil-793148fee9c46c3df8b7ca941d6c73d5c61bc3a8.tar.gz
fix Makefile for freebsd
-rw-r--r--Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 0dadfca3..4f4d1238 100644
--- a/Makefile
+++ b/Makefile
@@ -17,15 +17,13 @@ DEPS = \
twine \
virtualenv \
wheel
-
-ifeq ($(PYTHON), $(filter $(PYTHON), python python2 python2.7))
- DEPS += \
- futures \
- ipaddress \
- mock==1.0.1 \
- unittest2
-endif
-
+PY2_DEPS = \
+ futures \
+ ipaddress \
+ mock==1.0.1 \
+ unittest2
+DEPS += `$(PYTHON) -c \
+ "import sys; print('$(PY2_DEPS)' if sys.version_info[0] == 2 else '')"`
# In not in a virtualenv, add --user options for install commands.
INSTALL_OPTS = `$(PYTHON) -c \
"import sys; print('' if hasattr(sys, 'real_prefix') else '--user')"`