summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-12-17 21:25:16 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2020-12-17 21:25:16 +0100
commit29225d30cb8f51cf102064c36a1755cf96ca8db4 (patch)
treed9e2cde867fc4d17a04453884c9830e54d55d773
parent8734ad9828ad4c520563b39544cd3b310c2f4644 (diff)
downloadpsutil-29225d30cb8f51cf102064c36a1755cf96ca8db4.tar.gz
skip-appveyor
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
-rw-r--r--.github/workflows/ci.yml94
1 files changed, 46 insertions, 48 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index eb801b44..7ebcf08c 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -12,57 +12,57 @@
on: [push]
name: Build
jobs:
- # linux-macos-win:
- # name: ${{ matrix.os }}
- # runs-on: ${{ matrix.os }}
- # timeout-minutes: 30
- # strategy:
- # fail-fast: false
- # matrix:
- # # os: [ubuntu-latest, macos-latest, windows-latest]
- # os: [ubuntu-latest, macos-latest]
- # include:
- # - {name: Linux, python: '3.9', os: ubuntu-latest}
- # env:
- # CIBW_TEST_COMMAND:
- # PYTHONUNBUFFERED=1 make install &&
- # PYTHONUNBUFFERED=1 make test &&
- # PYTHONUNBUFFERED=1 make test-memleaks
- # CIBW_TEST_EXTRAS: test
- # CIBW_SKIP: cp35-* pp*
- # steps:
- # - name: Cancel previous runs
- # uses: styfle/cancel-workflow-action@0.6.0
- # with:
- # access_token: ${{ github.token }}
+ linux-macos-win:
+ name: ${{ matrix.os }}
+ runs-on: ${{ matrix.os }}
+ timeout-minutes: 30
+ strategy:
+ fail-fast: false
+ matrix:
+ # os: [ubuntu-latest, macos-latest, windows-latest]
+ os: [ubuntu-latest, macos-latest]
+ include:
+ - {name: Linux, python: '3.9', os: ubuntu-latest}
+ env:
+ CIBW_TEST_COMMAND:
+ PYTHONUNBUFFERED=1 make install &&
+ PYTHONUNBUFFERED=1 make test &&
+ PYTHONUNBUFFERED=1 make test-memleaks
+ CIBW_TEST_EXTRAS: test
+ CIBW_SKIP: cp35-* pp*
+ steps:
+ - name: Cancel previous runs
+ uses: styfle/cancel-workflow-action@0.6.0
+ with:
+ access_token: ${{ github.token }}
- # - uses: actions/checkout@v2
- # - uses: actions/setup-python@v2
- # with:
- # python-version: 3.9
+ - uses: actions/checkout@v2
+ - uses: actions/setup-python@v2
+ with:
+ python-version: 3.9
- # # - name: (Windows) install Visual C++ for Python 2.7
- # # if: matrix.os == 'windows-latest'
- # # run: |
- # # choco install vcpython27 -f -y
+ # - name: (Windows) install Visual C++ for Python 2.7
+ # if: matrix.os == 'windows-latest'
+ # run: |
+ # choco install vcpython27 -f -y
- # - name: Run tests
- # run: |
- # cibuildwheel .
+ - name: Run tests
+ run: |
+ cibuildwheel .
- # - name: Create wheels
- # uses: actions/upload-artifact@v2
- # with:
- # name: wheels
- # path: wheelhouse
+ - name: Create wheels
+ uses: actions/upload-artifact@v2
+ with:
+ name: wheels
+ path: wheelhouse
- # - name: Print hashes
- # if: matrix.os == 'ubuntu-latest'
- # run: |
- # make generate-manifest
- # python setup.py sdist
- # mv dist/psutil*.tar.gz wheelhouse/
- # python scripts/internal/print_hashes.py wheelhouse/
+ - name: Print hashes
+ if: matrix.os == 'ubuntu-latest'
+ run: |
+ make generate-manifest
+ python setup.py sdist
+ mv dist/psutil*.tar.gz wheelhouse/
+ python scripts/internal/print_hashes.py wheelhouse/
# freebsd:
# runs-on: macos-latest
@@ -115,8 +115,6 @@ jobs:
- uses: actions/setup-python@v2
- name: 'Linters'
run: |
- ls
- find .
python -m pip install flake8
python -m flake8 .
echo "flake8 linting OK"