summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-20 03:49:07 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-20 03:49:07 +0200
commit0d3e55a670887f865bb3c0ac9baaa86558f763e9 (patch)
treed24548bd143dd57614eb4910ba9b2b741d329f95
parent5e74fa53becb51c17c21e2867b79d5403081faf0 (diff)
downloadpsutil-0d3e55a670887f865bb3c0ac9baaa86558f763e9.tar.gz
import psutil right after make build to make sure compilation worked
-rw-r--r--Makefile5
-rwxr-xr-xscripts/internal/winmake.py7
2 files changed, 9 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index c44c6c02..f47d262c 100644
--- a/Makefile
+++ b/Makefile
@@ -63,20 +63,21 @@ _:
# Compile without installing.
build: _
+ # make sure setuptools is installed (needed for 'develop' / edit mode)
+ $(PYTHON) -c "import setuptools"
PYTHONWARNINGS=all $(PYTHON) setup.py build
@# copies compiled *.so files in ./psutil directory in order to allow
@# "import psutil" when using the interactive interpreter from within
@# this directory.
PYTHONWARNINGS=all $(PYTHON) setup.py build_ext -i
rm -rf tmp
+ $(PYTHON) -c "import psutil" # make sure it actually worked
# Install this package + GIT hooks. Install is done:
# - as the current user, in order to avoid permission issues
# - in development / edit mode, so that source can be modified on the fly
install:
${MAKE} build
- # make sure setuptools is installed (needed for 'develop' / edit mode)
- $(PYTHON) -c "import setuptools"
PYTHONWARNINGS=all $(PYTHON) setup.py develop $(INSTALL_OPTS)
rm -rf tmp
diff --git a/scripts/internal/winmake.py b/scripts/internal/winmake.py
index 40ba3742..57546bd6 100755
--- a/scripts/internal/winmake.py
+++ b/scripts/internal/winmake.py
@@ -192,11 +192,16 @@ def help():
@cmd
def build():
"""Build / compile"""
+ # Make sure setuptools is installed (needed for 'develop' /
+ # edit mode).
+ sh("%s -c import setuptools" % PYTHON)
sh("%s setup.py build" % PYTHON)
- # copies compiled *.pyd files in ./psutil directory in order to
+ # Copies compiled *.pyd files in ./psutil directory in order to
# allow "import psutil" when using the interactive interpreter
# from within this directory.
sh("%s setup.py build_ext -i" % PYTHON)
+ # Make sure it actually worked.
+ sh("%s -c 'import psutil'" % PYTHON)
@cmd