summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a3075012..dc18e62e 100644
--- a/Makefile
+++ b/Makefile
@@ -197,7 +197,7 @@ check-imports: ## Run isort linter.
check-c-code: ## Run C linter.
@git ls-files '*.c' '*.h' | xargs $(PYTHON) scripts/internal/clinter.py
-lint: ## Run all linters
+check-all: ## Run all linters
${MAKE} check-flake8
${MAKE} check-imports
${MAKE} check-c-code
@@ -213,6 +213,10 @@ fix-flake8: ## Run autopep8, fix some Python flake8 / pep8 issues.
fix-imports: ## Fix imports with isort.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg
+fix-all:
+ ${MAKE} fix-flake8
+ ${MAKE} fix-imports
+
# ===================================================================
# GIT
# ===================================================================