summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 16c7bb26..a0a70739 100644
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,7 @@ TSCRIPT = psutil/tests/runner.py
# Internal.
DEPS = \
argparse \
+ autoflake \
autopep8 \
check-manifest \
concurrencytest \
@@ -208,7 +209,8 @@ lint: ## Run all linters
# ===================================================================
fix-flake8: ## Run autopep8, fix some Python flake8 / pep8 issues.
- @git ls-files | grep \\.py$ | xargs $(PYTHON) -m autopep8 --in-place --jobs 0 --global-config=.flake8
+ git ls-files | grep \\.py$ | xargs $(PYTHON) -m autopep8 --in-place --jobs 0 --global-config=.flake8
+ git ls-files | grep \\.py$ | xargs $(PYTHON) -m autoflake --in-place --remove-all-unused-imports --remove-unused-variables
fix-imports: ## Fix imports with isort.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg