summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3a8dab59..80c3bc3c 100755
--- a/setup.py
+++ b/setup.py
@@ -106,8 +106,10 @@ def get_description():
stdout, stderr = p.communicate()
if p.returncode != 0:
raise RuntimeError(stderr)
- assert not stderr, stderr
- return stdout.decode('utf8')
+ data = stdout.decode('utf8')
+ if WINDOWS:
+ data = data.replace('\r\n', '\n')
+ return data
@contextlib.contextmanager