summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 8284f959..0f6716b3 100755
--- a/setup.py
+++ b/setup.py
@@ -77,7 +77,6 @@ extras_require = {"test": [
"enum34; python_version <= '3.4'",
"ipaddress; python_version < '3.0'",
"mock; python_version < '3.0'",
- "unittest2; python_version < '3.0'",
]}
if not PYPY:
extras_require['test'].extend([
@@ -361,7 +360,7 @@ def main():
author_email='g.rodola@gmail.com',
url='https://github.com/giampaolo/psutil',
platforms='Platform Independent',
- license='BSD',
+ license='BSD-3-Clause',
packages=['psutil', 'psutil.tests'],
ext_modules=extensions,
classifiers=[
@@ -392,7 +391,6 @@ def main():
'Operating System :: POSIX',
'Programming Language :: C',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: Implementation :: CPython',
@@ -414,7 +412,7 @@ def main():
)
if setuptools is not None:
kwargs.update(
- python_requires=">=2.6, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
extras_require=extras_require,
zip_safe=False,
)