summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-03-13 12:13:47 +0000
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-03-13 12:13:47 +0000
commit5730aa9a4055ad9b8ba5c4e40b7578cf3a565a24 (patch)
treed553650458ad38761ef9da7dd73f885099787d68
parent8ed0196d02086af3912706928d3b42d247dbbeca (diff)
downloadpsycopg2-5730aa9a4055ad9b8ba5c4e40b7578cf3a565a24.tar.gz
Less stuff in the readme, more in the docs
-rw-r--r--README.rst24
-rw-r--r--doc/src/install.rst7
2 files changed, 18 insertions, 13 deletions
diff --git a/README.rst b/README.rst
index efbe38e..f917992 100644
--- a/README.rst
+++ b/README.rst
@@ -21,7 +21,7 @@ Psycopg 2 is both Unicode and Python 3 friendly.
Documentation
-------------
-Documentation is included in the 'doc' directory and is `available online`__.
+Documentation is included in the ``doc`` directory and is `available online`__.
.. __: http://initd.org/psycopg/docs/
@@ -30,22 +30,20 @@ Installation
------------
If your ``pip`` version supports wheel_ packages it should be possible to
-install a binary version of Psycopg including all the dependencies. Just run::
+install a binary version of Psycopg including all the dependencies from PyPI_.
+Just run::
- pip install psycopg2
+ $ pip install -U pip # make sure your pip is up-to-date
+ $ pip install psycopg2
-If you want to build Psycopg from source you will need some prerequisite (a C
-compiler, Python and libpq development packages). If you have what you need
-the standard::
-
- python setup.py build
- sudo python setup.py install
-
-should work no problem. In case you have any problem check the 'install' and
-the 'faq' documents in the docs or online__.
+If you want to build Psycopg from source you will need some prerequisites (a C
+compiler, development packages): please check the install_ and the faq_
+documents in the ``doc`` dir for the details.
.. _wheel: http://pythonwheels.com/
-.. __: http://initd.org/psycopg/docs/install.html#install-from-source
+.. _PyPI: https://pypi.python.org/pypi/psycopg2
+.. _install: http://initd.org/psycopg/docs/install.html#install-from-source
+.. _faq: http://initd.org/psycopg/docs/faq.html#faq-compile
For any other resource (source code repository, bug tracker, mailing list)
please check the `project homepage`__.
diff --git a/doc/src/install.rst b/doc/src/install.rst
index 8290e67..e367b9c 100644
--- a/doc/src/install.rst
+++ b/doc/src/install.rst
@@ -133,6 +133,13 @@ from sources you will need:
You only need :program:`pg_config` to compile `!psycopg2`, not for its
regular usage.
+Once everything is in place it's just a matter of running the standard:
+
+.. code-block:: console
+
+ $ python setup.py build
+ $ python setup.py install
+
Runtime requirements
^^^^^^^^^^^^^^^^^^^^