summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-03-22 03:19:34 +0000
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-03-22 03:36:08 +0000
commit57b1093b31ddfbe7434ca02dc172f088d4747396 (patch)
tree154cc8926627c115a51c0c5e239d1750edab9aee
parent7214c6652e579ebf8b52c41473f7253866b3d646 (diff)
downloadpsycopg2-57b1093b31ddfbe7434ca02dc172f088d4747396.tar.gz
Find again mxDateTime includes in default locations
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4912ee7..09c6f84 100644
--- a/setup.py
+++ b/setup.py
@@ -528,9 +528,10 @@ have_mxdatetime = False
use_pydatetime = int(parser.get('build_ext', 'use_pydatetime'))
# check for mx package
+mxincludedir = ''
if parser.has_option('build_ext', 'mx_include_dir'):
mxincludedir = parser.get('build_ext', 'mx_include_dir')
-else:
+if not mxincludedir:
mxincludedir = os.path.join(get_python_inc(plat_specific=1), "mx")
if mxincludedir.strip() and os.path.exists(mxincludedir):
# Build the support for mx: we will check at runtime if it can be imported