summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-03-13 16:50:57 +0000
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-03-13 16:50:57 +0000
commitef9f9f5fff848d2e0f12896ed4568272c3f93c5c (patch)
treea8920849a70d6be2fee8fc381d9d7378012de766
parent5730aa9a4055ad9b8ba5c4e40b7578cf3a565a24 (diff)
downloadpsycopg2-ef9f9f5fff848d2e0f12896ed4568272c3f93c5c.tar.gz
Improved notes to release psycopg packages
-rw-r--r--doc/release.rst60
1 files changed, 45 insertions, 15 deletions
diff --git a/doc/release.rst b/doc/release.rst
index c9f5cd4..00399c7 100644
--- a/doc/release.rst
+++ b/doc/release.rst
@@ -1,16 +1,32 @@
How to make a psycopg2 release
==============================
-- Edit ``setup.py`` and set a stable version release. Use PEP 440 as reversion
- numbers, e.g. ``2.7``.
+- Edit ``setup.py`` and set a stable version release. Use PEP 440 to choose
+ version numbers, e.g.
-- Push psycopg2 to master or to the maint branch. Make sure tests pass.
- in the `Travis settings`__ you may want to be sure that the varialbes
+ - ``2.7``: a new major release, new features
+ - ``2.7.1``: a bugfix release
+ - ``2.7.1.1``: a release to fix packaging problems
+ - ``2.7.2.dev0``: version held during development, non-public test packages...
+ - ``2.8b1``: a beta for public tests
+
+ In the rest of this document we assume you have exported the version number
+ into an environment variable, e.g.::
+
+ $ export VERSION=2.7
+
+- In the `Travis settings`__ you may want to be sure that the variables
``TEST_PAST`` and ``TEST_FUTURE`` are set to a nonzero string to check all
the supported postgres version.
.. __: https://travis-ci.org/psycopg/psycopg2/settings
+- Push psycopg2 to master or to the maint branch. Make sure tests on Travis__
+ and AppVeyor__ pass.
+
+.. __: https://travis-ci.org/psycopg/psycopg2
+.. __: https://ci.appveyor.com/project/psycopg/psycopg2
+
- For an extra test merge or rebase the `test_i686`__ branch on the commit to
release and push it too: this will test with Python 32 bits and debug
versions.
@@ -41,34 +57,48 @@ How to make a psycopg2 release
.. __: https://ci.appveyor.com/project/psycopg/psycopg2-wheels
.. __: http://initd.org/psycopg/upload/
-- Download the packages generated::
+- Download the packages generated (this assumes ssh configured properly)::
+
+ $ rsync -arv initd-upload:psycopg2-${VERSION} .
- $ rsync -arv initd.org:/home/upload/upload/psycopg2-2.7 .
+- Sign the packages and upload the signatures back::
-- Sign the packages and upload the signatures back. This assumes you have a
- pkey configured to upload::
+ $ for f in psycopg2-${VERSION}/*.{exe,tar.gz,whl}; do \
+ gpg --armor --detach-sign $f;
+ done
- $ for f in psycopg2-2.7/*.{exe,tar.gz,whl}; do gpg --armor --detach-sign $f; done
- $ rsync -arv -i ~/.ssh/id_rsa-initd-upload psycopg2-2.7 upload@initd.org:
+ $ rsync -arv psycopg2-${VERSION} initd-upload:
- Run the ``copy-tarball.sh`` script on the server to copy the uploaded files
in the `tarballs`__ dir::
- ssh psycoweb /home/psycoweb/copy-tarball.sh \
- /home/upload/upload/psycopg2-2.7/psycopg2-2.7.tar.gz
+ $ ssh psycoweb@initd.org copy-tarball.sh ${VERSION}
.. __: http://initd.org/psycopg/tarballs/
- Remove the ``.exe`` from the dir, because we don't want to upload them on
PyPI::
- for f in psycopg2-2.7/*.exe; do rm -v $f $f.asc; done
+ $ rm -v psycopg2-${VERSION}/*.exe{,.asc}
-- Upload the packages on PyPI::
+- Only for stable packages: upload the packages and signatures on PyPI::
- twine upload psycopg2-2.7/*
+ $ twine upload psycopg2-${VERSION}/*
- Create a release and release notes in the psycopg website, announce to
psycopg and pgsql-announce mailing lists.
- Edit ``setup.py`` changing the version again (e.g. go to ``2.7.1.dev0``).
+
+
+Releasing test packages
+-----------------------
+
+Test packages may be uploaded on the `PyPI testing site`__ using::
+
+ $ twine upload -r testpypi psycopg2-${VERSION}/*
+
+assuming `proper configuration`__ of ``~/.pypirc``.
+
+.. __: https://testpypi.python.org/pypi/psycopg2
+.. __: https://wiki.python.org/moin/TestPyPI