summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-06-28 06:28:50 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2018-07-12 18:07:25 -0700
commit61e644049fb5fea153d7da944bc0f33b7f169b0f (patch)
treefe56667a44f6e553ca561ed8832dde6e9af48d52
parent6becf0ef550e8eb0c241c3835b1466eef37b1784 (diff)
downloadpsycopg2-61e644049fb5fea153d7da944bc0f33b7f169b0f.tar.gz
Add testing and document support for Python 3.7
Python 3.7 was released on June 27, 2018. https://docs.python.org/3/whatsnew/3.7.html
-rw-r--r--.appveyor.yml4
-rw-r--r--.travis.yml16
-rw-r--r--doc/src/install.rst2
-rwxr-xr-xscripts/travis_prepare.sh4
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
6 files changed, 18 insertions, 11 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 1761e99..d85d3ef 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -21,6 +21,9 @@ environment:
- {PYVER: "35", PYTHON_ARCH: "64"}
- {PYVER: "36", PYTHON_ARCH: "32"}
- {PYVER: "36", PYTHON_ARCH: "64"}
+ - {PYVER: "37", PYTHON_ARCH: "32"}
+ - {PYVER: "37", PYTHON_ARCH: "64"}
+
OPENSSL_VERSION: "1_0_2n"
POSTGRES_VERSION: "10_1"
@@ -64,6 +67,7 @@ init:
- IF "%PYVER%"=="34" SET VS_VER=10.0
- IF "%PYVER%"=="35" SET VS_VER=14.0
- IF "%PYVER%"=="36" SET VS_VER=14.0
+ - IF "%PYVER%"=="37" SET VS_VER=14.0
- IF "%VS_VER%"=="10.0" IF "%PYTHON_ARCH%"=="64" SET DISTUTILS_USE_SDK=1
diff --git a/.travis.yml b/.travis.yml
index 51cba9a..a40e807 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,15 +1,17 @@
# Travis CI configuration file for psycopg2
-dist: trusty
+dist: xenial
sudo: required
language: python
-python:
- - 2.7
- - 3.7-dev
- - 3.6
- - 3.5
- - 3.4
+matrix:
+ include:
+ - python: 2.7
+ - python: 3.7
+ - python: 3.6
+ - python: 3.5
+ - python: 3.4
+ dist: trusty
install:
- pip install -U pip setuptools wheel
diff --git a/doc/src/install.rst b/doc/src/install.rst
index f60b3c8..a65cd21 100644
--- a/doc/src/install.rst
+++ b/doc/src/install.rst
@@ -33,7 +33,7 @@ The current `!psycopg2` implementation supports:
NOTE: keep consistent with setup.py and the /features/ page.
- Python version 2.7
-- Python 3 versions from 3.4 to 3.6
+- Python 3 versions from 3.4 to 3.7
- PostgreSQL server versions from 7.4 to 10
- PostgreSQL client library version from 9.1
diff --git a/scripts/travis_prepare.sh b/scripts/travis_prepare.sh
index 73cbb84..71045c6 100755
--- a/scripts/travis_prepare.sh
+++ b/scripts/travis_prepare.sh
@@ -38,7 +38,7 @@ create () {
export PGBIN="$PGDIR/bin"
# install postgres versions not available on the image
- if (( "$VERNUM" < 902 || "$VERNUM" > 906 )); then
+ if [[ ! -d "${PGDIR}" ]]; then
wget -O - http://initd.org/psycopg/upload/postgresql/postgresql-${PACKAGE}.tar.bz2 \
| sudo tar xjf - -C /usr/lib/postgresql
fi
@@ -109,7 +109,6 @@ if [[ -z "$DONT_TEST_PRESENT" ]]; then
create 9.6
create 9.5
create 9.4
- create 9.3
fi
# Unsupported postgres versions that we still support
@@ -124,6 +123,7 @@ if [[ -n "$TEST_PAST" ]]; then
create 9.0
create 9.1
create 9.2
+ create 9.3
fi
# Postgres built from master
diff --git a/setup.py b/setup.py
index f2e8260..b8badee 100644
--- a/setup.py
+++ b/setup.py
@@ -67,6 +67,7 @@ Programming Language :: Python :: 3
Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
+Programming Language :: Python :: 3.7
Programming Language :: Python :: Implementation :: CPython
Programming Language :: C
Programming Language :: SQL
diff --git a/tox.ini b/tox.ini
index a0eafa4..df6b5b9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py{27,34,35,36}
+envlist = py{27,34,35,36,37}
[testenv]
commands = make check