summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2021-06-15 18:28:13 +0100
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2021-06-15 18:28:13 +0100
commit37ab1d8877614ad4fff2943848db97bfa3e516a9 (patch)
tree53aa41d9de0f1ccbb2217b814f5f7f5ebc7cb558
parent1d3a89a0bba621dc1cc9b32db6d241bd2da85ad1 (diff)
downloadpsycopg2-37ab1d8877614ad4fff2943848db97bfa3e516a9.tar.gz
Bump to a new dev version number to try to release new packages
-rw-r--r--setup.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 2c49cf4..87cbe1d 100644
--- a/setup.py
+++ b/setup.py
@@ -33,7 +33,6 @@ import re
import subprocess
from setuptools import setup, Extension
from distutils.command.build_ext import build_ext
-from distutils.sysconfig import get_python_inc
from distutils.ccompiler import get_default_compiler
from distutils.errors import CompileError
@@ -45,7 +44,7 @@ except ImportError:
# Take a look at https://www.python.org/dev/peps/pep-0440/
# for a consistent versioning pattern.
-PSYCOPG_VERSION = '2.9.dev0'
+PSYCOPG_VERSION = '2.9.dev1'
# note: if you are changing the list of supported Python version please fix
@@ -114,7 +113,8 @@ For further information please check the 'doc/src/install.rst' file (also at
stdout=subprocess.PIPE,
stderr=subprocess.PIPE)
except OSError:
- raise Warning(f"Unable to find 'pg_config' file in '{self.pg_config_exe}'")
+ raise Warning(
+ f"Unable to find 'pg_config' file in '{self.pg_config_exe}'")
pg_config_process.stdin.close()
result = pg_config_process.stdout.readline().strip()
if not result:
@@ -404,7 +404,8 @@ For further information please check the 'doc/src/install.rst' file (also at
pgpatch = int(pgpatch)
else:
sys.stderr.write(
- f"Error: could not determine PostgreSQL version from '{pgversion}'")
+ f"Error: could not determine PostgreSQL version from "
+ f"'{pgversion}'")
sys.exit(1)
define_macros.append(("PG_VERSION_NUM", "%d%02d%02d" %