summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2021-11-05 18:37:58 +0100
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2021-11-05 18:37:58 +0100
commit1454b14ae0102fa08279c9fec92289b3734ad959 (patch)
tree623b629f1e4ee851505b48d8f1e73fed143e8a93
parent8e186dd7e93218effd6a1fa26f173224f97df9a4 (diff)
downloadpsycopg2-1454b14ae0102fa08279c9fec92289b3734ad959.tar.gz
Fix Python 3.10 and PostgreSQL 14 compatibility notes
-rw-r--r--doc/src/install.rst4
-rw-r--r--setup.py3
2 files changed, 4 insertions, 3 deletions
diff --git a/doc/src/install.rst b/doc/src/install.rst
index fb66310..8d22137 100644
--- a/doc/src/install.rst
+++ b/doc/src/install.rst
@@ -131,8 +131,8 @@ The current `!psycopg2` implementation supports:
..
NOTE: keep consistent with setup.py and the /features/ page.
-- Python versions from 3.6 to 3.9
-- PostgreSQL server versions from 7.4 to 13
+- Python versions from 3.6 to 3.10
+- PostgreSQL server versions from 7.4 to 14
- PostgreSQL client library version from 9.1
diff --git a/setup.py b/setup.py
index 8137ef6..33ac44c 100644
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,7 @@ except ImportError:
# Take a look at https://www.python.org/dev/peps/pep-0440/
# for a consistent versioning pattern.
-PSYCOPG_VERSION = '2.9.1'
+PSYCOPG_VERSION = '2.9.2.dev0'
# note: if you are changing the list of supported Python version please fix
@@ -59,6 +59,7 @@ Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
+Programming Language :: Python :: 3.10
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: Implementation :: CPython
Programming Language :: C