summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2021-11-03 13:13:58 +0100
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2021-11-03 14:16:38 +0100
commit6b80bd0648bb9413689b06eb6915dec522830674 (patch)
tree655bffd14955116adbca1609ad91b514bd0f5633
parent4a46aa39a5842887f100ad1fafad55d207497f40 (diff)
downloadpsycopg2-6b80bd0648bb9413689b06eb6915dec522830674.tar.gz
Drop Windows exe package build
-rw-r--r--.appveyor/packages.yml2
-rw-r--r--doc/release.rst5
-rwxr-xr-xscripts/build/appveyor.py4
3 files changed, 0 insertions, 11 deletions
diff --git a/.appveyor/packages.yml b/.appveyor/packages.yml
index 5822e56..cc1fae5 100644
--- a/.appveyor/packages.yml
+++ b/.appveyor/packages.yml
@@ -83,8 +83,6 @@ test_script:
artifacts:
- path: dist\psycopg2-*\*.whl
name: wheel
- - path: dist\psycopg2-*\*.exe
- name: exe
# vim: set ts=4 sts=4 sw=4:
diff --git a/doc/release.rst b/doc/release.rst
index a49ec7e..088bfa4 100644
--- a/doc/release.rst
+++ b/doc/release.rst
@@ -54,11 +54,6 @@ How to make a psycopg2 release
``scripts/build`` directory. They will be saved in a
``packages/psycopg2-${VERSION}`` directory.
-- Remove the ``.exe`` from the dir, because we don't want to upload them on
- PyPI::
-
- $ rm -v packages/psycopg2-${VERSION}/*.exe
-
- Only for stable packages: upload the signed packages on PyPI::
$ twine upload -s packages/psycopg2-${VERSION}/*
diff --git a/scripts/build/appveyor.py b/scripts/build/appveyor.py
index bd65007..4d312b1 100755
--- a/scripts/build/appveyor.py
+++ b/scripts/build/appveyor.py
@@ -326,10 +326,6 @@ def build_binary_packages():
add_pg_config_path()
- # Build .exe packages for whom still use them
- if opt.package_name == 'psycopg2':
- run_python(['setup.py', 'bdist_wininst', "-d", opt.dist_dir])
-
# Build .whl packages
run_python(['setup.py', 'bdist_wheel', "-d", opt.dist_dir])