summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2011-01-02 02:37:36 +0100
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2011-01-02 02:44:56 +0100
commitafb87bb10a0858daeb1a4d0d3b5078599aaed7c1 (patch)
tree75d76cadfea8139d07e71c34de6a25c5dab52578 /Makefile
parentd08bfcbee55c65e8a88e05d75522d8d29f093f21 (diff)
downloadpsycopg2-afb87bb10a0858daeb1a4d0d3b5078599aaed7c1.tar.gz
Fixed "building" of purelib files with make.
Using build instead of build_py forced build_ext to run too, which may fail to run as the option PG_CONFIG is not passed (or, worse, we may end up building against the wrong pg_config). Also touching the target file as make seems considering the source file newer than the destination when the timestamp is the same (as it is because the file is usually just copied).
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ffc7cc5..47cfd15 100644
--- a/Makefile
+++ b/Makefile
@@ -104,7 +104,8 @@ $(PLATLIB): $(SOURCE_C)
$(PYTHON) setup.py build_ext $(BUILD_EXT_OPT)
$(PACKAGE)/%.py: lib/%.py
- $(PYTHON) setup.py build $(BUILD_OPT)
+ $(PYTHON) setup.py build_py $(BUILD_OPT)
+ touch $@
$(SDIST): docs MANIFEST $(SOURCE)