summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2010-12-12 16:50:29 +0000
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2010-12-21 04:02:13 +0000
commit9b29282ee477609052545aef0492b3f0461e7879 (patch)
tree8b962fe1398abfc353c9a61040e64e5669de6cc4 /Makefile
parent31093a7a58462617bd4646c7a6613754d761b566 (diff)
downloadpsycopg2-9b29282ee477609052545aef0492b3f0461e7879.tar.gz
'make check' runs the test in the build directory.
This way tests can be run win Py3 too, as the setup 2to3s them.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 9ecf15f..12617f0 100644
--- a/Makefile
+++ b/Makefile
@@ -82,7 +82,7 @@ ez_setup:
wget -O $(EZ_SETUP) http://peak.telecommunity.com/dist/ez_setup.py
check:
- PYTHONPATH=$(BUILD_DIR):.:$(PYTHONPATH) $(PYTHON) tests/__init__.py --verbose
+ PYTHONPATH=$(BUILD_DIR):$(BUILD_DIR)/tests:$(PYTHONPATH) $(PYTHON) $(BUILD_DIR)/psycopg2/tests/__init__.py --verbose
testdb:
@echo "* Creating $(TESTDB)"