summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-02-08 18:09:15 +0000
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-02-08 18:09:15 +0000
commit4b78ca4405d0ddfc587343003625c06798d25ac2 (patch)
tree69814095c71bd148c1de5449483c2addcec29b9a /setup.py
parent21fbe2bd2a8558d1c957902f6508662d6983736f (diff)
downloadpsycopg2-4b78ca4405d0ddfc587343003625c06798d25ac2.tar.gz
Fixed generation of download url from beta version
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c797370..4d23436 100644
--- a/setup.py
+++ b/setup.py
@@ -609,7 +609,8 @@ ext.append(Extension("psycopg2._psycopg", sources,
# using these pretty metadata. But that's their problem, not ours.
download_url = (
"http://initd.org/psycopg/tarballs/PSYCOPG-%s/psycopg2-%s.tar.gz"
- % ('-'.join(PSYCOPG_VERSION.split('.')[:2]), PSYCOPG_VERSION))
+ % (re.sub(r'^(\d+)\.(\d+).*', r'\1-\2', PSYCOPG_VERSION),
+ PSYCOPG_VERSION))
try:
f = open("README.rst")